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1.1  Group Exercise-1: Create Terrain by Alternate Surface 

1) Open Perry\J9P3093\Corridors_J9P3093.dgn 

 

2) Review project setup.  AC is mainline Corridor; TG is sideroad Corridor and two linear 

templates are in the radius return area at the intersection of AC & TG. 

 

3) Review Template Drop on mainline AC Corridor. 

 

a. Use the Active Template Tab and review the Alternate Surfaces for the 

Template. 

 

4) Create a new file named Terrain_Proposed_J9P3093.dgn using the following Seed file: 

MoDOT_Roadway_Seed_3D.dgn 

 

5) Open the Coordinate System tool by selecting the OpenRoads Modeling Workflow ➔ 

Utilities Tab ➔ Geographic Section. 

 

6) Select “From File” icon. 

 

 
 

7) Select the Terrain_Existing_J9P3093.dgn file in the data. 

 

8) Verify the settings.  
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9) Reference in the following files: 

 

Corridors_J9P3093.dgn (Default 2D View)  

Terrain_Existing_J9P3093.dgn 

 

Important - Set the terrain active after referencing it in. 

 

Note: Creating a Terrain Model with an Alternate Surface(s) will work with any 

Corridor or Linear Template Feature Definition. 

 

10) Choose the Create Corridor Alternate Surfaces tool by selecting the OpenRoads 

Modeling Workflow ➔ Terrain Tab ➔ Create Section ➔ Additional Methods Tools 

and then select the “AC” Corridor and wait. 

 

 
 

11) After creating the Alternate Surface Terran Models, detach all reference files, select 

“Yes” below to break the rules back to the reference files. 

 

 
   

 

12) There are three Alternate Surface Terrain Models created, rotate the view to see the 

terrain models RTEAC.Proposed Finished Grade, RTEAC.Subgrade, and 

RTEAC.Bottom of Pavement. 
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13) Use the Explorer ➔ OpenRoads Model Group ➔ Terrain Models to delete the 

AC.Subgrade  and RTEAC.Bottom of Pavement terrain models. 

 

14) Set the RTEAC.Proposed Finished Grade Terrain Model to have a Feature Definition 

of Design Triangles. 

 

15) Rotate the view to top and select fit view. 

 

16) Select Terrain > Edit> Edit Model tool. 

a. Edit the Terrain model. 

 

 
 

Additional Notes:  

 

• Alternate Surface(s) can only process one corridor at a time. 

• The Create Corridor Alternate Surfaces tool works with Referenced 

Corridors, in other words you don’t need to be in the Corridors file for the 

tool to work. 

• Alternate Surfaces do have rules back to the original Corridor and 

template. 

• With Alternate Surfaces, to get the End Conditions included in the terrain 

model, typically the existing ground must be referenced and active. 

• The Terrain Edit Tools can modify the newly created Terrain Models 

from the Alternate Surfaces Tool only after the rules have been dropped 

back to the Corridor. 

• When you remove the Rules from the Terrain Model you break the link 

back to the Corridor. 

• The Corridor Feature Definition can modify the number of triangles 

created based on the multiplication interval being applied. 
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1.2  Group Exercise-2: Create Terrain by Graphical Filter 

The following steps will show the User how to create a Terrain Model of the Proposed Surface 

using the Design - Proposed Finished Grade with Boundary Graphic Filter.  The Graphic 

Filter uses points along the entire proposed finished grade surface which includes but is not 

limited to side-slope conditions, top of pavement, top of shoulder, curb, etc.  A Terrain Boundary 

will also be incorporated that includes the points that make up the Limits of Construction (LOC 

points). 

 

1) Open Perry\J9P3093\Corridors_J9P3093.dgn 

 

2) Verify the Corridor Feature Definition is set to a Final-x 1 for the RTEAC and TG 

Corridors, as well as the Radius Return Linear Templates. 

 

3) Open the Terrain_Proposed_J9P3093.dgn. 

a) If not already done so, Delete and Detach everything in the file. 

b) Compress File by Selecting File ➔ Tools ➔ Compress File 

 

4) Reference in Corridors_J9P3093.dgn (Default 2D View). 

a) If needed rotate the view to “Top” and fit the view. 

 

5) Within the OpenRoads Modeling Workflow, select Terrain Model ➔ Create ➔ From 

Graphical Filter tool and choose the following:  

a) Graphical Filter Group: Design - Proposed Finished Grade with Boundary 

b) Select the Preview Button 

a. Linear Elements in the surface of the model should highlight. 

c) Edge Method: None  

d) Feature Definition: Design Triangles 

e) Name: Proposed Terrain from Graphic Filter 

 

Note: When the tool is activated the Corridors 3D View is automatically referenced into the 

drawing. 
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6) Notice in the Project Explorer that the Filter Group and Individual Filters were copied 

over into the active file. 

 

Explorer ➔ OpenRoads Standards ➔ Terrain_Proposed_J9P3093.dgn ➔ Terrain 

Filters 

 

7) Detach both references (2D and 3D) to the Corridors_J9P3093.dgn. 

 

 

Additional Notes: 

 

• Terrain Models created from Graphic Filters do not have rules back to the original 

Corridor and template. 

• Graphic Filters can process all Corridors and Linear Templates at the same time. 

• The Graphic Filters tool works with Referenced Corridors, in other words you don’t 

need to be in the Corridors file for the tool to work. 

• The Terrain Edit tools can modify the newly created Terrain Models created from the 

Graphic Filters tool. 

• The Corridor Feature Definition can modify the number of triangles created based on 

the multiplication interval being applied. 

• Compressing a file will purge deleted elements and clears the undo buffer. 
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1.3 Individual Exercise-3: Create Terrain by Graphical Filter 

The following steps will show the User how to create a Terrain Model of the Proposed Surface 

using the Design – Bottom of Base with Boundary Graphic Filter.  The Graphic Filter uses 

points along the entire proposed finished grade surface which includes but is not limited to side-

slope conditions, top of pavement, top of shoulder, curb, etc.  A Terrain Boundary will also be 

incorporated that includes the points that make up the Limits of Construction (LOC points). 

 

 

1) Open Perry\J9P3093\Corridors_J9P3093.dgn 

 

2) Verify the Corridor Feature Definition is set to a Final-x 1 for the RTEAC and TG 

Corridors, as well as the Radius Return Linear Templates. 

 

3) Open the Terrain_Proposed_J9P3093.dgn. 

a) If not already done so, Delete and Detach everything in the file. 

b) Compress File by Selecting File ➔ Tools ➔ Compress File 

 

4) Reference in Corridors_J9P3093.dgn (Default 2D View). 

a. If needed rotate the view to “Top” and fit the view. 

 

5) Within the OpenRoads Modeling Workflow, select Terrain Model ➔ Create ➔ From 

Graphical Filter tool and choose the following:  

b. Graphical Filter Group: Design - Bottom of Base - Daylighted with Boundary 

i. Select the Preview Button 

ii. Linear elements in the surface of the model should highlight. 

c. Edge Method: None  

d. Feature Definition: Design Triangles 

e. Name: Proposed Terrain from Graphic Filter 
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Note: When the tool is activated the Corridors 3D View is automatically referenced into the 

drawing. 

 

6) Notice in the Project Explorer that the Filter Group and Individual Filters were copied 

over into the active file. 

 

Explorer ➔ OpenRoads Standards ➔ Terrain_Proposed_J9P3093.dgn ➔ Terrain 

Filters 

 

7) Detach both references (2D and 3D) to the Corridors_J9P3093.dgn 

 

Additional Notes: 

 

• Terrain Models created from Graphic Filters do not have rules back to the original 

Corridor and template. 

• Graphic Filters can process all Corridors and Linear Templates at the same time. 

• The Graphic Filters tool works with Referenced Corridors, in other words you don’t 

need to be in the Corridors file for the tool to work. 

• The Terrain Edit tools can modify the newly created Terrain Models created from the 

Graphic Filters tool. 

• The Corridor Feature Definition can modify the number of triangles created based on 

the multiplication interval being applied. 

• Compressing a file will purge deleted elements and clears the undo buffer. 
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1.4 Group Exercise-4: Create Terrain from Elements (Linear 

Features) 

1) Open Perry\J9P3093\Corridors_J9P3093.dgn 

 

2) Verify the Corridor Feature Definition is set to a 4-Final-x 1 – Linear Features Only 

for the RTEAC and TG Corridors, as well as the Radius Return Linear Templates. 

 

3) Select the “F6” key to open the 3D view of the Model. 

 

4) Open the Terrain_Proposed_J9P3093.dgn. 

a) If not already done so, Delete and Detach everything in the file. 

b) Compress File by Selecting File ➔ Tools ➔ Compress File 

 

5) Reference in Corridors_J9P3093.dgn (Default 3D View). 

a) In the Reference Dialog turn off the display of the Corridors 2D view 

b) If needed rotate the view to “Top” and fit the view. 

 

6) Use the Level Manager and only display the “Surface” Levels. 
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7) Using the Element Section Tool place all 38 visible items in a Selection Set. 

 

8) Within the OpenRoads Modeling Workflow, select 

Terrain Model Tab ➔ Create Section ➔ From 

Elements tool and choose the following:  

 

 

 

 

 

 

 

 

9) To reduce the long Exterior Triangles that don’t represent the proposed linear features, 

we will change the Limits of Construction elements to a Boundary Feature Type. 

 

To help with the selection of Limits of Construction elements, we will utilize the Level 

Display dialog and the Display Set tool.  In the Level Display dialog Right Click on the 

Modeling-Limits of Construction level and Right Click, then select Create Display Set. 

 

(NO levels need to be turned off beforehand, for the Display Set to work). 

 

Then using a section fence place the Modeling-Limits of Construction elements into a 

Selection Set. 
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10) Using the Element Section Tool place all 10 visible items in a Selection Set.  

 

11) Once Selection Set is created, right-click and hold in a blank area and select View 

Control ➔ Displayset Clear.  The 10 elements should still be in a selection set. 

 

12) Within the OpenRoads Modeling Workflow, select Terrain Model Tab ➔ Edit Section 

➔ Change Feature Type tool and choose the following:  

 

 
 

 

 

 

Additional Notes:  

 

• The Create Terrain from Elements tool works with Referenced 

Corridors, in other words you don’t need to be in the Corridors file for the 

tool to work. 

• Create Terrain from Elements Surfaces do not have rules back to the 

original Corridor and template elements. 

• The Corridor Feature Definition can modify the number of triangles 

created based on the multiplication interval being applied. 

• Compressing a file will purge deleted elements and clears the undo buffer. 
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1.5 Group Exercise-5: Create Terrain from Design Meshes 

1) Open Perry\J9P3093\Corridors_J9P3093.dgn  

 

2) In the 2D Default view, change the Design Stage to 2-Final x 1 Top Mesh Only for all 

Linear Templates and Corridors. 

 

3) Open Perry\J9P3093\Terrain_Proposed_J9P3093.dgn 

a. If not already done so, Delete and Detach everything in the file. 

 

4) Reference in Corridors_J9P3093.dgn (Default 2D View). 

a. In the Reference Dialog turn off the display of the Corridors 2D view 

b. If needed rotate the view to “Top” and fit the view. 

 

5) Within the OpenRoads Modeling Workflow, select Terrain Model Tab ➔ Create 

Section ➔ Addition Methods Tools ➔ Create Terrain from Design Meshes tool and 

choose the following:  

  
5) Detach both reference files and rotate the view. 

 

6) Using the Terrain Model heads-up tools select the terrain model Export tool and select 

Land XML. 

 

 

 

 

 

 Additional Notes:  

 

• The Create Terrain from Design Meshes tool works with Referenced 

Corridors, in other words you don’t need to be in the Corridors file for the 

tool to work. 

• Create Terrain from Design Meshes Surfaces do not have rules back to 

the original Corridor and template elements. 

• The Corridor Feature Definition can modify the number of triangles 

created based on the multiplication interval being applied. 

Select Terrain:  Design Triangles 

Export Format: Land XML (.xml) 

Project Name:  J9P3093 

Project Description: AC Corridor Proposed Terrain 

Export Options: Export Triangles Only 
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1.1 Group Exercise: Bridge End-Bent Layout 

 

1) Open the Pike\J2P3081\Exported_Graphics_J2P3081.dgn. 

a) Review the Existing Survey Graphics. 

b) Using the Level Display turn off all levels except for the following levels: 

a. Survey-Edge of Pavement 

 

2) Add a Feature Definition of EOP Existing to the Survey-Edge of Pavement elements 

(4 elements) 

 

3) Create a new file named Civil_Geometry_J2P3081.dgn using the 

MoDOT_Roadway_Seed_2D.dgn as the seed file. 

 

4) Open the Coordinate System tool by selecting the OpenRoads Modeling Workflow ➔ 

Utilities Tab ➔ Geographic Section. 

 

5) Select “From File” icon. 

 

a. Choose the Existing_Terrain_J2P3081.dgn 

 

 

 

 

 

 

 

 

 

 

 

 

6) Set Annotation Scale to 50 

 

7) Import Alignment and Profile called “Mainline” and “Proposed” from the mainline.xml 

 

8) Rename the alignment to Route 14  

 

9) Annotate the Route 14 alignment. 

 

10) Reference in the following: 

a. Exported_Graphics_J2P3081.dgn  

b. Existing_Terrain_J2P3081 

 

11) Activate the Existing Ground Terrain  

 

12) Hover over the Route 14 alignment and verify that there is an active profile. 
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13)  Open Plan_J2P3081.dgn File. 

a) Attach Civil_Geometry_J2P3081.dgn 

b) Review plan geometry. 

 

14)  Create a new file named Corridors_J2P3081.dgn using the 

MoDOT_Roadway_Seed_2D.dgn as the seed file. 

 

15)  Assign the GCS (Geographic Coordinate System) from file. 

 

16) Set Annotation Scale to 50 

 

17) Reference in the following files: 

a) Civil_Geometry_J2P3081.dgn 

b) Existing_Terrain_J2P3081.dgn 

c) Exported_Graphics_J2P3081.dgn 

d) Plan_J2P3081.dgn 

 

18)  Activate Existing Ground Terrain. 

 

19) Next select the “F6” key to open the multi-model view.  In the 3D View turn Off the 

Display of the Exported_Graphics_J2P3081.dgn 

 

20) Turn off the Level Common-Notes in the Plan_J2P3081.dgn  referenced file 

 

21)  Verify all the Levels in the Exported Graphics_J2P3081.dgn are turned off except for 

the Survey-Edge of pavement. 

 

22)  Open the Project Template Library J2P3081.itl. 

a) Review the Bridge template  

b) Review the Roadway templates  

c) Close Template Library. 

 

23) Create a Corridor for Route 14 using the Create Corridor tool 

a) Name the corridor “Route14” 

b) Apply Roadway template “J2P3081 2 Lane w/ Agg Base Option 1 Mill and Fill 

Concrete Widening” from station 68+00 to 71+68.64 R1 with Drop Interval of 5ft. 

c) If not open already select the “F6” key to open 3D view of model. 
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24)  Review the LT_Seek_Surface point in the template drop to verify that the Horizontal 

Feature Constraint is defined as EOP Existing for the Feature Definition.  Do the same 

for the RT_Seek_Surface point. 

 
 

25) Review the LT_Conc_T_EOP point in the template drop to verify that the Horizontal 

Feature Constraint is defined as EOP New for the Feature Definition.  Do the same for 

the RT_Conc_T_EOP point. 

 

26) Close the Editing Roadway Designer Template Drop dialog. 

 

27) Add the two EOP New and two EOP Existing lines as Corridor References.  

 

28)  Add the following Parametric Constraint to remove Pavement Widening on Left side 

ending at Station 70+52.89. 

 

 

 

 

 

 

 

29)  To help with placement of a Horizontal Temporary Dimension Line in the next step, 

add in a Key Station at 71+68.63 (make sure the Dynamic Cross Section Model is not 

open while executing this step, it will cause incorrect slope values). 

 

30) Open Dynamic XS model, and display XS at Station 71+68.63 R1 

a) Verify that the pavement slopes on left and right side by adding horizontal 

dimensioning to the left and right side of pavement. 

b) Left = 0.52% Right = -0.79% 

 

Note:  If after using the Horizontal Dimension Tool, if you notice a “Dimension” 

message on the end your Cursor, that won’t go away, selecting the tool again will 

remove that message. 

Start:   68+00.00 

Stop:   70+52.89 

Constraint Label: LT_Pvmt_Surf_Conc_Width 

Start Value:  0.00 

Stop Value:  0.00 
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31) Apply Roadway/Bridge Approach template. 

 

a) Review Concrete Approach Pavement with Barrier Template (focus on Display 

Rule for Type “B” Barrier) 

b) Apply Concrete Approach Pavement with Barrier from station 71+68.65 R1 to 

72+37.00 R1 

c) Use a drop spacing of 1ft 

 

32)  Add the following two Parametric Constraints to transition the Overlay Pavement 

Slopes onto the Concrete Approach Pavement Slopes:  

Parametric Constraint #1 

 

 

 

 

 

 

Parametric Constraint #2 

 

 

 

 

 

 

 

• Note if gap in slope between the two templates is not resolved, check to make sure the 

existing ground terrain is active. 

 

33)  Create a terrain model from the 3D Model.  This terrain Model will be used to create 

a profile around the Bridge End Bent. 

 

a) Create new file called Graphic_Filter_J2P3081.dgn 

using a 3D Seed. 

b) Assign the GCS (Geographic Coordinate System) 

from file. 

c) Reference in the Corridors_J2P3081.dgn and its 

Default-3D view. 

d) Select the Create Terrain Model From Graphical 

Filter. 

e) Use a Filter Group called Design – Proposed Finish 

Grade with Boundary. 

f) Use Feature Definition of Design Triangles. 

g) Name the new Terrain model “J2P3081 Terrain from 

Graphic Filter” 

h) Detach All References and Dynamically Rotate the 

View to view the new terrain. 

 

Start:   71+68.65 

Stop:   71+78.65 

Constraint Label: LT_Pvmt_Surf_Conc_Slope 

Start Value:  0.52% 

Stop Value:  2.0% 

Start:   71+68.65 

Stop:   71+78.65 

Constraint Label: RT_Pvmt_Surf_Conc_Slope 

Start Value:  -0.79% 

Stop Value:  -2.0% 
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Create Horizontal and Vertical Civil Alignment End Bent Corridor: 

 

34) Open Civil_Geometry_J2P3081.dgn 

 

a) Reference in Plan_J2P3081.dgn (Default 2D Model) 

b) Use Horizontal Geometry Complex by PI Tool and trace end bent counterclockwise. 

a. Use radius of 0.00’ 

b. Use Feature Definition > Bridge_Approach_Slab_503-10.00 

i. (Located under: Linear\Design\Safety and Structures) 

c. Use Feature Name “End_Bent_1” 

c) Reference in Graphic_Filter_J2P3081.dgn  

a. If triangles are turned on, go into the properties of the Terrain Model and 

override the symbology and turn triangles off. 

d) Select End Bent 1’s Alignment and open its Profile Model. 

 

35) Use Vertical Geometry Tool Quick Profile from Surface to create a profile from Graphic 

Filter Surface. 

 

a) Set profile Active. 

b) To be safe Remove Rules to the newly created profile before performing the next 

step.  

c) In Default 2D view Detach the Graphic_Filter_J2P3081.dgn 

 

36) Open Corridors_J2P3081.dgn file 

 

37)  Add the Traffic Control Barrier Lines near the End Bent as Corridor References. 

 

Note: You will notice that after adding the Corridor References the Type B Barriers are 

still not displaying.  Investigate and solve the reason why. 

 

38) Add the following two Parametric Constraints to transition into the Guardrail Widening 

Width over a distance of 10ft near the Bridge Approach slab: 

 

Parametric Constraint #1 

 

 

 

 

 

Parametric Constraint #2 

 

 

 

 

 

Note: The rest of the Guardrail Widening behind the Type B Barrier will be removed in 

another step later in this exercise. 

Start:   71+87.89 

Stop:   71+97.89 

Constraint Label: LT_Guardrail_Widening_Width 

Start Value:  -3.9375’ 

Stop Value:  -1.50' 

Start:   72+00.52 

Stop:   72+10.52 

Constraint Label: RT_Guardrail_Widening_Width 

Start Value:  3.9375’ 

Stop Value:  1.50' 
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39)  Review below the Guardrail Widening Width requirements on the right side of Route14 to 

meet our requirements in the Standard Plans 606.80. 

 

 

 

Using the Law of Sines calculate the transition Length.  

 
𝑎

sin⁡ 𝐴
⁡= 

𝑏

sin⁡𝐵
 

7ft

sin⁡(15°)
⁡= 

𝑏

sin⁡(90°−15°)
   

 

𝑏 = (
sin75°

sin15°
)⁡(7𝑓𝑡) = 26.12ft, use 30ft for Guardrail Widening Transition Distance. 

 

40)  Modify the Guardrail Widening Width requirements on both sides of the Mainline using 

the following Parametric Constraints to meet MoDOT’s requirements in Standard Plans 

606.80. 

 

Parametric Constraint #1 

 

 

 

 

 

Parametric Constraint #2 

 

 

  

 

 

Parametric Constraint #3 

 

 

 

 

 

𝑎 
𝐴 

𝑏 

𝐵 

Start:   Start of Alignment 

Stop:   68+70 

Constraint Label: Guardrail_Widening_Width 

Start Value:  0.00 ft 

Stop Value:  0.00 ft 

Start:   68+70 

Stop:   69+00 

Constraint Label: Guardrail_Widening_Width 

Start Value:  0.00 ft 

Stop Value:  7.00 ft   (-7.00 ft for left side) 

Start:   69+00 

Stop:   69+30 

Constraint Label: Guardrail_Widening_Width  

Start Value:  7.00 ft   (-7.00 ft for left side) 

Stop Value:  3.9375 ft   (-3.9375 ft for left side) 
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41)  In the Corridors_J2P3081.dgn 2D Default View, if it is on, turn off the 3D reference 

from the Corridors 3D Model. 

  

42) Set the Feature Definition to: Alignment/Guardrail_Type_A _LT or RT (UFDT) 

 
 

Make sure the following are active:  

 

  Use Active Feature Definition 

  Create 3D Automatically 

 

  Use Feature Definition Template 

 

43)  Using the Horizontal Geometry - Variable Offset Taper along with Civil AccuDraw 

tool, place on BOTH Left and Right sides of the roadway the 1ft offset taper section of the 

guardrail. 

 

 Variable Offset Taper Settings 

 

Notes: 

• If in the 3D View the 

guardrail looks like a block, 

go into the View Attributes 

and turn off the Construcion 

View. 

• If a very tall guardrail post draw, select the “F4” Key.  

  

44)  Using the Horizontal Geometry – Single Offset Partial along with Civil AccuDraw tool, 

place on the LEFT side of the roadway the following section of the guardrail. 
 

Single Offset Partial Settings Left 
 

 

  

 

 

 

 Variable Offset Taper Settings Left 
 

 

 

 

  

 
 

Locate Element: Proposed Edge of Shoulder 

Start Offset:  1.00 

End Offset:  0.00 

Start Station:  69+00 

End Station:  69+30 

Feature Definition: Guardrail_Type_A_LT/RT (UFDT) 

Locate Element: Proposed Edge of Shoulder 

Offset:   0.00 

Start Station:  69+30 

End Station:  71+80.11 

Feature Definition: Guardrail_Type_A_ Left (UFDT) 

Locate Element: Proposed Edge of Shoulder 

Start Offset:  0.00 

End Offset:  -0.50 

Start Station:  71+80.11 

End Station:  71+98.49 

Feature Definition: Guardrail_Type_A_ Left (UFDT) 
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NOTE: You’ll notice that the Guardrail meanders in and out, (especially on the left side) 

because it is tied to the edge of shoulder line.  To remove the meander tie the outside 

shoulder line to the baseline at a 16 feet offset, in other words within the 

LT_Conc_T_O_EOS point make the parent point of the Horizontal Constraint be the 

AsphSurf_T_CL point and set the distance to -16 feet. 

 

45)  Using the Horizontal Geometry – Single Offset Partial along with Civil AccuDraw tool, 

place on the Right side of the roadway the following section of the guardrail. 

 

Single Offset Partial Settings Right 
 

 

  

 

 

 

 

Variable Offset Taper Settings Right 
 

 

  

 

 

 

 

Note: In the 3D View the best visualization setting is Illistration: Modeling and adjust the 

Brightness.  To get back to the default views hit the F6 key. 

 

46)  Create/Apply a Linear Template Drop for End Bent #1.  To see the End Bent Geometry 

in the 2D View you may need to turn ON the Roadway-Edge of Pavement level within 

the Level Display for the Reference File Civil_Geometry_J2P308.dgn 

 

 

 

 

 

 

 

 

 

 

 

 

 

47)  Add Corridor Clip to the Mainline Corridor 

a. Clip out the End Bent Linear Template. 

 

Locate Element: Proposed Edge of Shoulder 

Offset:   0.00 

Start Station:  69+30 

End Station:  71+98.75 

Feature Definition: Guardrail_Type_A_Right (UFDT) 

Locate Element: Proposed Edge of Shoulder 

Start Offset:  0.00 

End Offset:  0.50 

Start Station:  71+98.75 

End Station:  72+11.02 

Feature Definition: Guardrail_Type_A_Right (UFDT) 

Locate Element:  The End_Bent_1 Horizontal Linear Feature 

Start Station:   Lock to Start 

End Station:   Lock to End 

Exterior Sweep Angle: 5 degrees 

Mirror:    No 

Reflect:   No 

Template:   2:1 Earth Slopes with Upper Concrete Structure 

Feature Definition:  1-Final x 1 

Description:   End Bent 1 
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48)  Using Parametric Constraints adjust the End Bent #1 Linear Template Drop: 

 

Parametric Constraint #1 

         (Bench Width) 

 

 

 

 

Parametric Constraint #2 

         (Bench Width) 

 

 

 

 

 

Parametric Constraint #3 

         (Wall Depth) 

 

 

 

 

Parametric Constraint #4 

         (Wall Depth) 

 

 

 

 

 

 

Parametric Constraint #5 

         (Fill Slope) 

 

 

 

 

Parametric Constraint #6 

         (Fill Slope) 

 

 

 

 

 

 

 

 

Start:   Lock to Start 

Stop:   0+25.00 

Constraint Label: Bench_Width 

Start Value:  0.00 ft 

Stop Value:  0.00 ft 

Start:   0+61.90 

Stop:   Lock to End 

Constraint Label: Bench_Width 

Start Value:  0.00 ft 

Stop Value:  0.00 ft 

Start:   Lock to Start 

Stop:   0+25.00 

Constraint Label: Wall_Depth 

Start Value:  0.00 ft 

Stop Value:  -4.00 ft 

Start:   0+61.90 

Stop:   Lock to End 

Constraint Label: Wall_Depth 

Start Value:  -4.00 ft 

Stop Value:  0.00 ft 

Start:   Lock to Start 

Stop:   0+25.00  

Constraint Label: Fill Slope 

Start Value:  -25% 

Stop Value:  -50% 

Start:   0+61.90 

Stop:   Lock to End 

Constraint Label: Fill Slope 

Start Value:  -50% 

Stop Value:  -25% 
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49) After applying the Parametric Constraints in the previous step you should notice slopes 

from the Mainline still solving and not being fully clipped out (see below). 

   
 

To remove the two slopes we are going to apply a End Condition Exception to the 

Mainline Corridor for each side of the roadway. 

 

End Condition Exception #1 

         (Right Side) 

 

 

 

 

End Condition Exception #2 

         (Left Side) 

 

 

 

 

 
 

50) To help close the gap near the start of the Barrier on the left side of the roadway, add a 

Key Station at 71+97.88 

 

Name:   Remove Right End Condition 

Apply ECE TO: Backbone Only (Right) 

Start:   72+10.53 

Stop:   72+50  

Name:   Remove Left End Condition 

Apply ECE TO: Backbone Only (Left) 

Start:   71+97.89 

Stop:   72+50  
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51) To Clip out the remaining piece of the Mainline Corridor, we are going to create a 

Clipping Block.  We will place the Clipping Block in the Plan_J2P3081.dgn file. 

a. Use the MicroStation Move Parallel tool and offset end bent line. 

 

b. Offset the bent line 0.01 up-station and down-station using the copy option 

within the MicroStation Move/Copy Parallel tool.   

 

c. We are offsetting the line twice because we are going to make two Clipping 

Blocks, one for the clipping out part of the Mainline Corridor and another for 

clipping out part of the future Bridge Corridor. 

 

 
 

d. Extend the offset lines well past Corridor Limits using the Extend Line tool. 
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e. Select the Place Block tool and set the method to Rotated. 

   

f. Create two block shapes. One up-station and one down-station using the copied 

offset lines by using a keypoint snap to each end of the extended line. You will 

want them to overlap. 
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52) Open Corridors_J2P3081.dgn 

a. Add Clipping Reference to Route14 (Mainline) Corridor using the newly created 

block. 

 

53) Create a new 2D file for the Bridge Corridor named Corridors_Bridge_J2P3081.dgn. 

a. Set the GCS using the Existing_Terrain_J2P3081.dgn 

b. Reference in the following: 

i. Civil_Geometry_J2P3081.dgn 

ii. Existing_Terrain_J2P3081.dgn 

iii. Plan_J2P3081.dgn 

c. Select F6 to open the 2D and 3D window 

 

54) Create a Corridor named Bridge using the Mainline Alignment. 

 

55)  Add the Bridge Template using the following settings: 

 

 

 

 

 

 

 

 

56)  Add a Clipping Reference to the Bridge Corridor using the down station block shape. 

 

57)  Open Corridors_J2P3081.dgn 

a. In the 3D View reference in the 3D Model  of the Corridors_Bridge_J2P3081.dgn  

b. Review Project 

 

 

 

 

 

 

 

END OF EXERCISE 

Corridor Name: Bridge 

Template:  Bridge 

Start Station:  72+20 

End Station:  73+50 

Drop Interval:  25.00’  
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2.1 Objectives 

The objective of this chapter is to give the user an overview of the Civil Design Tools and 

the design workflow using these tools.  The user will learn how to access the tools, set 

preferences, navigate through the Create Template and Civil Tool dialog boxes. Designing 

an intersection can be a complex and iterative process. There are an abundance of criteria 

to consider such as min/max slopes, stopping sight distance, drainage and R/W constraints 

– just to name a few. 

There are many techniques utilizing Horizontal, Vertical and Corridor Civil Tools that can 

be used to model intersections. This chapter will cover the workflow used to model a Tee-

intersection.  In addition, this method may be used to model an intersection where the 

mainline roadway is within the limits of a horizontal curve.  This method will ultimately 

work for most intersection types. 
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2.2 Intersection Design Exercise 

1. Within the Cole\J5P0100\ folder, open the file: Plan_Overview_J5P0100.dgn 

2. Zoom in to the location where Ramp 2 and Ramp 4 intersect Big Horn Drive. 

 

 

Note: Ramp 2 station at Big Horn is 16+55.31 and Ramp 4 at Big Horn is 0+00.  The 

Ramps run in opposite directions. 

 

Creating the Project Template Library  

3. Within the OpenRoads Modeling Workflow, select Create Template by selecting the 

Corridors Tab ➔ Create Section ➔ Template Tools.   

 

 

4. Select File > Save As from the Create Template dialog menu.  Save the MoDOT 

template library as J5P0100.itl in the  folder. 

5. Within the itl create a folder named J5P0100 to store templates for the Project Corridors.   

6. Within to the J5P0100 folder and create a new folder called Big Horn. 

Path to MoDOT itl ➔ Documents\CADD_Standards\ORD Standards\Connect_Config\WorkSpaces\MoDOT\Standards\Template Library\ 
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7. Copy within the Big Horn Folder the 

following Template: 

 Templates ➔ Overlay ➔ Overlay w/ 

Asphalt Pavement Widening and A2 

Shoulder - Option #3 ➔ Match Existing 

Slope Surface Course. 

8. Rename Template to Big Horn - Match 

Existing Slope Surface Course 

9. To get the Widening to start at the Existing 

Edge of pavement edit the Big Horn - 

Match Existing Slope Surface Course Template and select the RT_AsphSurf_B_EOP 

and the LT_AsphSurf_B_EOP points and modify the Horizontal Feature Constraint 

to be Linear\Design\Roadway\EOP_Existing 

 

 

 

 

 

 

 

 

 

 

 

 

For the previous step edit the following 

area in the Point Property dialog: 
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10. Close the J5P0100.itl Template Library and Save on exit. 
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Creating the Big Horn Corridor  

11. Create the Corridor dgn file for all the alignments going into the Intersection of Big 

Horn, Ramp 2, and Ramp 4. 

12. Create a new dgn file named Corridors_J5P0100.dgn using the: 

  MoDOT_Roadway_Seed_2D.dgn seed file. 

 Note: This new file will hold all the Corridors for this intersection. 

13. Open the Coordinate System tool by selecting the OpenRoads Modeling Workflow ➔ 

Utilities Tab ➔ Geographic Section. 

14. Select “From File” icon. 

 

15. Select the Terrain_Existing_J5P0100.dgn file in the data folder. 

16. Verify the settings.  

  

17. Reference in the following files within the Default 2D Model: 

Civil_Geometry_J5P0100.dgn 

Terrain_Existing_J5P0100.dgn 

18. Fit View, change the Annotation Scale to 1” = 50’, and set the Existing Terrain as 

Active. 
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19. Create a Corridor for Big Horn Drive     

a. Open the New Corridor tool by selecting the OpenRoads Modeling Workflow ➔ 

Corridors Tab ➔ Create Section 

b. Select the Big Horn Alignment 

c. Right Click for the Active Profile (Big Horn Existing). 

d. Corridor Name: Big Horn 

e. Template: J5P0100 ➔ Big Horn ➔ Big Horn - Match Existing Slope Surface 

Course 

f. Start Station 0+97.77 (Start of Alignment) 

g. End Station 21+48.29 (End of Alignment) 

h. Drop Interval 5’  

 

20. Select F6 to view the 3D model of the Corridor. 

21. To allow the template to see the Big Horn Existing Edge of Pavement (EOP) lines we 

need to set a “Design” Feature Definition on those lines.  Currently the Big Horn EOP 

Existing lines have a “Survey” Feature Definition applied to them, which does not 

currently work with ORD Corridor Modeling.   

To resolve this, let’s open the Exported_Graphics_J5P0100.dgn file and update the 

EOP Existing Feature Definitions. 

22. Using the Level Display, turn off all levels except for Survey-Edge of Pavement. 

23. Set the Feature Definition Toggle Bar with the following settings: 

 

Linear ➔ Design ➔ Roadway ➔ EOP Existing 

Also make sure the Use Active Feature Definition is toggle ON. 

 Open the Set Feature Definitions tool by selecting the OpenRoads Modeling Workflow 

➔ Geometry Tab ➔ General Tools Section ➔ Standards Pull-Down.  Then select and 

“Set” the two Existing EOP lines. 
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24. Reopen the Corridors_J5P0100.dgn file and then open a Dynamic XS view for the Big 

Horn Corridor.  Also add a Horizontal Temporary Dimension Line in the Overlay 

Area of the template. 

 

25. Reference into the Default 2D Model the following files: 

Exported_Graphics_J5P0100.dgn 

26. For the Corridor to see the Existing Edge of Pavement line, the line needs to be added as 

a Corridor Reference.  To add a Corridor Reference, select the corridor’s heads up tools 

and select the 4th set of tools from the left and select Add Corridor Reference.  

 

The start of the Edge of Widening offset should have changed from the default 8’ offset 

defined in the template to the actual distance to the Existing Edge of Pavement line. 

 

Note: Horizontal Feature Constraint Range Explained: 

  

• Range uses the offsets as defined in the template.  For example, if your point is 

defined at 38 offset in the template, and the range is -18, the point will look from 38 

to 20 offset from the corridor baseline for the feature definition. 

• Positive (+) values entered, will cause the template to look only to the Right of the 

Template point. 
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• Negative (-) values entered, will cause the template to look only to the Left of the 

Template point. 

• A Zero (0) value entered, will cause the template to look both left and right of the 

Template point. 

• The start location of the Range is always the original offset location of the Point in 

the Template.  Even if the point is shifted to a different offset in the model, for 

example a point being shifted using Parametric Constraint, the start location of the 

Range is always the original offset location of the Point in the Template. 

• A Horizontal Feature Constraint Range can be overwritten with a Point Control 

using a Control Type called Feature Definition, the program will determine the 

offset of the point that is assigned the Point Control and apply the range value to the 

offset of that point as it exists in the template. 

• If there are two or more Features within the Horizontal Feature Constraint Range, 

the closest one to original offset location of the Point in the Template will be selected. 
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27. Next, we are going to define the amount of widening.  The max amount of Widening will 

be 12’ left and right of the centerline of Big Horn. 

 To get the Widening to stop at an offset of 12’ from the baseline we will need to modify 

the Big Horn - Match Existing Slope Surface Course Template.  To do this select the 

RT_AsphSurf_T_EOP1 and the LT_AsphSurf_T_EOP1 points and modify the 

Horizontal Constraint to have a parent point AsphSurf_B_CL with an Offset = 12 ft 

For the previous step edit the following area in the Point Property dialog: 
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28. Close the J5P0100.itl Template Library and Save on exit. 

29. Reopen a Dynamic XS view for the Big Horn Corridor.  Verify the 12’ Widening Limit 

by using a Horizontal Temporary Dimension Line. 
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Creating the Ramp Corridors  

30. Create a Corridor for Ramp2 

a. Open the New Corridor tool by selecting the OpenRoads Modeling Workflow ➔ 

Corridors Tab ➔ Create Section 

b. Select the Ramp 2 Alignment 

c. Right Click for the Active Profile (Ramp 2 Proposed). 

d. Corridor Name: Ramp 2 

e. Corridor Feature Definition: 0-Preliminary x 5 

f. Template: Components  ➔ Pavement - New ➔ Asphalt Pavement w/Shoulders ➔ 

A2 Shoulders Agg Base ➔ Asphalt Pavement 1 Lane w/Agg Base Asphalt 

Shoulder. 

g. Start Station 13+00, End Station Lock to End, and Drop Interval 5’  

 

  

 

 

 

 

 

31. Modify the Template Drop in the dgn:  

a. Make the Template Origin point AsphSurf_T_EOP  

b. Remove the point constraints from AsphSurf_T_EOP. 

c. Change the AsphSurf_T_EOP Feature Definition to XS_AsphSurf_CL 

d. Add Horizontal and Slope Constraints to the AsphSurf_T_CL from point 

AsphSurf_T_EOP, horizontally -18’ @ -2% slope. 

e. Change the AsphSurf_T_CL Feature Definition to XS_AsphSurf_EOP 

f. Add Guardrail Widening to the outside Edge of Shoulder:  

End Conditions ➔ Combined ➔ Guardrail Widening 

g. Add a 6:1 Fill or 6:1 Foreslope and Back Ditch End Condition to the right side of 

the Guardrail Widening:  

End Conditions ➔ Combined ➔ 6:1 Fill or 6:1 Foreslope and Back Ditch 

h. Change the AsphSurf_T_O_EOS point properties from a Vector-Offset constraint 

to a Slope Constraint 2% sloping downward. 

i. 
 Click OK to save the Template 
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32. From the OpenRoads Modeling Workflow, select Create Template by selecting the 

Corridors Tab ➔ Create Section ➔ Template Tools. 

 

33. Navigate to the J5P0100 folder and create a new folder called Ramps. 

a. From the Create Template dialog select Tools ➔ Template Library Organizer 

b. Copy the Asphalt Pavement 1 Lane w/Agg Base Asphalt Shoulder to the J5P0100 

➔ Ramps Folder 

 

 

 

 

 

 

 

c. Close, Save, and Check In the Template Library when prompted 

34. Create a Corridor for Ramp4 

a. Open the New Corridor tool by selecting the OpenRoads Modeling Workflow ➔ 

Corridors Tab ➔ Create Section 

b. Select the Ramp 4 Alignment 

c. Right Click for the Active Profile (Ramp 4 Proposed). 

d. Corridor Name: Ramp 4 

e. Corridor Feature Definition: 0-Preliminary x 5 

f. Template: J5P0100  ➔ Ramps ➔ Asphalt Pavement 1 Lane w/Agg Base Asphalt 

Shoulder. 

g. Start Station 0+56, End Station 3+55, and Drop Interval 5’  
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35. Add a Point Control to Ramp4 corridor for both Vertical and Horizontal to meet 

Ramp2 corridor. (Note:  Make sure all references are displayed in the view) 

a. Open the Point Control Tool from the Ramp 4 heads up display 

b. Set the Start Station 0+00 

c. Set the End Station 3+55 

d. Control Description: Ramp4 Match Ramp2 

e. Point: AsphSurf_T_CL 

f. Mode: Both 

g. Control Type: Corridor Feature  

h. Corridor: Ramp2 

i. Reference Feature: 3D Linear Element 

AsphSurf_T_CL 

j. Priority: 1 

k. Horizontal and Vertical Offsets: 0 
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NOTE: There appears to be a problem with the Ramp 2 Profile. The Ramp 2 Profile is 

supposed to be designed so that the Crown Point in-between the Ramp 2 and Ramp 4 

Corridors matches the elevation of the Big Horn EOP/EOP line.  You can see in the 3D 

view that the Ramp 2 Corridor is diving too far below into the Big Horn Corridor. 

  

 

 

 

 

 

 

 

 

 

 

 

 

36. Open the Civil_Geometry_J5P0100.dgn file  

37. Reference in the 2D Model of the Corridors_J5P0100.dgn. 

38. Make the terrain active 
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39. Open the Profile Model for Ramp 2 and zoom in to an area near the end of the profile. 

Utilizing the Create 3D Cut tool (the third icon from the right), and the Corners option, 

place a box around the end of the profile.  You can see that the profile is not ending 

anywhere near the EOP/EOS point of the Big Horn Template. 

 

Adjust the Station and Elevation of the end of the Profile to the following: 

     Station = 16+43.31 

     Elevation = 764.57 (See calculations below.)  
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40. Open the Corridors_J5P0100.dgn file to see the adjustments to the Ramp 2 Corridor 

modeling up to the EOP/EOS point of Big Horn. 

 

Creating the Radius Return Linear Templates  

41. Reopen the Civil_Geometry_J5P0100.dgn file. 

42. Using the Feature Definition Toggle Bar set the Feature Definition to 

MoDOT_Baseline_Proposed (located under Alignment) and toggle on Use Active 

Feature Definition. 

43. For the SW Radius Return, select the “Simple Arc” tool by selecting the OpenRoads 

Modeling Workflow, then Geometry Tab ➔ Horizontal Section ➔ Arc Tools ➔ Arc 

Between Elements. 

a. First select the EOP line (Baseline) of Ramp2 and then the EOP line of Big 

Horn Drive to place the Arc. 

b. Use a radius of 75. 

c. Trim: None 

d. Name: SW 

 

 

 

 

 

 

 

44. For the NW Radius Return, use the same Simple Arc tool with a radius of 75. 

a. First select the EOP of Big Horn Drive then the EOP (Baseline) for Ramp4. 

(Important to go in this order so the same template can be used later) 

b. Use a radius of 75. 

c. Trim: None 

d. Name: NW 
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45. Define the Start Station (0+00) for each radius return as indicated below using the 

“Start Station” tool.  To do this select the OpenRoads Modeling Workflow, then 

Geometry Tab ➔ Horizontal Section ➔ Modify Tools ➔ Start Station 
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46. In the next few steps, we are going to define a profile for the Radius Returns based on the 

longitudinal slopes of the edge of pavements coming into each Radius Return.   

First, we are going to use the Project Extended Profile tool to view the longitudinal 

EOP slope coming into and out of the Radius Returns.  Then we will us the Quick 

Profile Transition tool to define the transition profile between the two extended profiles. 

The Project Extended Profile tool is located under the OpenRoads Modeling 

Workflow, Geometry Tab ➔ Vertical Section ➔ Profile Creation Tools. 

The Quick Profile Transition tool is located under the OpenRoads Modeling 

Workflow, Geometry Tab ➔ Vertical Section ➔ Element Profiles Tools. 

 

NW Radius Return:   

a. Open the Profile Model for the NW Radius Return. 

b. Using the Project Extended Profile tool place both longitudinal new Edge of 

Pavement profile slopes coming into the Radius Returns.  Use a Feature 

Definition of EOP New (located under Linear ➔ Design ➔ Roadway). 

 

c. Apply a vertical profile to the NW radius return using the Quick Profile 

Transition tool. Using the Parabolic method with a Feature Definition of 

MoDOT_Baseline_Proposed (located under Alignment). 

d. Name the Profile: NW Proposed 
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Note: The Quick Profile Transition tool will automatically make the newly created profile 

Active. 

47. Drop the Rules of the newly created NW Proposed Profile. 

48. (Individual Step) Using the same steps in storing a profile for the NW Radius Return, 

store a profile for the SW Radius Return (start on Step 46). 

49. Do not do the following step until both the SW and NW profiles have been stored. 

Detach the Corridors_J5P0100.dgn file from the Civil_Geometry_J5P0100.dgn file.  

When prompted, break the rules between the two files.  The Extended Profiles (white 

lines) should disappear from both the NW and SW Profile models leaving the Proposed 

Profiles (yellow lines). 

50. Open the Corridors_J5P0100.dgn file. 

51. Select the NW Radius Return’s alignment and open the heads-up tools and then select 

Apply Linear Template. 

 

52. Set the Apply Linear Template dialog up as follows: 

 

53. Individually select the Big Horn and Ramp 4 corridors and select their heads-up tools 

and add the NW Linear Template as a Clipping Reference. 
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Radius Return Linear Templates draw to Big Horn Edge of Pavement 

Next, we are going to make the Left EOP in the NW template (AsphSurf_T_CL) draw 

up to the Right Outside Edge of Pavement in the Big Horn template 

(RT_AsphSurf_T_EOP1).   

To do this we will use a Point Control.   

 

 

 

 

 

 

 

 

 

 

 

 

 

But first, another piece of information we will need for our Point Control is the Start and 

Stop Location for drawing to the Big Horn Edge of Pavement.  With the NW Linear 

Template, we will start at Sta. 0+00 and end at Sta. 0+68.45 
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54. Using the heads-up prompts on the NW Linear Template grips, select the Corridor 

Creation Tools ➔ Point Controls 

 

 
Fill out Point Control dialog as shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

55. (Individual Step) Using the same steps in storing the NW Linear Template, that drew 

the NW EOP up to the Big Horn EOP.  Create a Linear Template and then a Point 

Control for the SW Radius Return that does the same thing.  (These steps started back 

on step 51). 

Start Station:   Lock to Start 

Stop Station:  0+68.45 

Control Description: Draw NW EOP to Big 

Horn EOP 

Point:   AsphSurf_T_CL 

Mode:   Both 

Control Type:  Corridor Feature 

Corridor:  Big Horn 

Reference Feature: RT_AsphSurf_T_EOP1 

Priority:  1 

Start Horz. Offset: 0 

Stop Horz. Offset: 0 

Start Vertical Offset: 0 

Stop Vertical Offset: 0 

 

Note: You will use the same Template that was used in the NW Linear Template. 
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Radius Return Linear Templates draw to Ramp 2 Edge of Pavement 

In the second part of modeling our NW and SW Linear Templates we are going to use 

another Point Control to draw the EOP up to the Ramp 2 EOP line. 

 

56. Using the heads-Up prompts on the NW Linear Template grips, select the Corridor 

Creation tools ➔ Point Controls.  Fill out dialog as indicated below: 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Start Station:   0+68.45 

Stop Station:  Lock to End 

Control Description: Draw NW EOP to Ramp 2 EOP 

Point:   AsphSurf_T_CL 

Mode:   Both 

Control Type:  Corridor Feature 

Corridor:  Ramp 2 

Reference Feature: AsphSurf_T_CL 

Priority:  1 

Start Horz. Offset: 0 

Stop Horz. Offset: 0 

Start Vertical Offset: 0 

Stop Vertical Offset: 0 
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57. (Individual Step) Using the same steps in storing the NW Linear Template, that drew 

the NW EOP up to the Ramp 2 EOP.  Create a Point Control for the SW Radius 

Return that does the same thing. 

 

Hint: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Start Station:   Lock to Start 

Stop Station:  0+50.90 

Control Description: Draw SW EOP to Ramp 2 EOP 

Point:   AsphSurf_T_CL 

Mode:   Both 

Control Type:  Corridor Feature 

Corridor:  Ramp 2 

Reference Feature: AsphSurf_T_CL 

Priority:  1 

Start Horz. Offset: 0 

Stop Horz. Offset: 0 

Start Vertical Offset: 0 

Stop Vertical Offset: 0 
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Modeling Bonus Steps: 

58. If your model has a vertical slice sticking up at the Big Horn EOP (see below)… 

 
 

You may need to add a slight offset to the SW Linear Template Point Control.  To do 

this select the Corridor Objects icon from the SW Linear Template heads-up tools.  

 

After selecting Point Control in the Corridor 

Objects dialog edit the Big Horn EOP Point 

Control. Add a -0.0001 Horizontal Offset to both the 

Start and Stop Offset (See Below). 
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Modeling Bonus Steps (Continued): 

59. If your model has a mismatched ditch between the NW Linear Template and the Ramp 

4 Corridor (see below)… 

 
 

You may need to change the Corridor Feature Definition for the Ramp 4 Corridor 

from 0-Preliminary x5 to 1-Final x1. 

 

Also, from the Ramp 4 Corridor add in a Key Station at 0+87.01. 
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Creating a Right Turn Only Grassy Island 

 

60. Open the Cole/J5P0100/Roadway/data/Corridors_J5P0100.dgn (If not in it already). 

61. From the Corridors file, we will create a Terrain Surface from the NW and SW Linear 

Templates to use as a reference surface to create a profile for the island. Press F6 to 

make sure the 3D window is open. 

Before we create the terrain, first switch the NW and SW Linear Template Feature 

Definition to 2-Final x 1 Top Mesh Only.  To do this you go into the Properties of the 

Linear Template.  
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62. Within the 3D Model and a Top View first select the SW Radius Return Linear 

Template. 

  

 

 

 

 

 

 

 

 

 

 

 

 

The corridor road surface highlights. 

63. Next, select the NW Radius Return Linear Template. 

 

 



Intersection Design                      OpenRoads Designer Road 2  
 

12/23/25 Missouri Department of Transportation 29  

64. To create the Terrain, select the From Elements tool by selecting the OpenRoads 

Modeling Workflow ➔ Terrain Tab ➔ Create Section. 

Fill out the dialog as follows: 

 

Left-Click to accept two previously selected elements. 

Left-Click to accept the option of Breakline for the type. 

For Edge Method: Max Triangle Length of 10 

65. Press F4 to clear out the tool. 

66. Next, we are going to export the terrain to a new file via an XML file.  To export the file 

to XML we are going to utilize the Explorer Tool. 

To open Explorer, select the OpenRoads Modeling Workflow ➔ Home Tab ➔ 

Primary Section. 

67. Within Explorer select the 

OpenRoads Model section: 
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68. Right click on the Island Terrain model and select Export Terrain Model ➔ LandXML 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

69. Fill out the Export Terrain to LandXML dialog as follows: 

 

 

 

 

 

 

 

 

Select Terrain:  Island 

Export Format: LandXML (.xml) 

Project Name:  (Optional) use J5P0100 

Project Description: (Optional) 

Export Options: Export Triangles Only 
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70. Once exported, delete the Island Terrain in the Corridors_J5P0100.dgn file.  Also 

switch the Linear Template Feature back to 1-Final x 1. 

71. Next, we are going create a NEW DGN file to store our Island Terrain. 

Create a new dgn file named Terrain_Proposed_J5P0100.dgn using the 

MoDOT_Roadway_Seed_3D.dgn seed file. 

72. Open the Coordinate System tool by selecting the OpenRoads Modeling Workflow ➔ 

Utilities Tab ➔ Geographic Section. 

73. Select “From File” icon. 

 

74. Select the Terrain_Existing_J5P0100.dgn file in the data folder. 

75. Verify the settings.  
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76. In this step we are going to import the Terrain Model.  To open the Create from File tool 

select the OpenRoads Modeling Workflow ➔ Terrain Tab ➔ Create Section.  Fill out 

the dialog as follows and select Import: 
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LandXML Import Options  

 

• Definition - Utilizes the stored triangulated faces to define the Terrain  

• Source - Utilizes survey features such as breaklines, voids and points, then 

triangulates. 

• Source and Definition (default) Utilizes both in creating the terrain. 

 

Notes: These import options are unique to LandXML files.  Best Practice on 

which LandXML Build Terrain From Option to use: 
 

• The method used will usually depend on the file and the situation.  

• If you do not want to re-triangulate (i.e. you want to duplicate the 

triangles from the terrain that generated the LandXML file), then use the 

Definition method.  

• Otherwise, the default (and recommended method) is to use Source and Definition. 

This does re-triangulate, but uses both triangles and source data to produce a “best” 

triangulation. 

 

77. Open the Cole/J5P0100/Roadway/data/Civil_Geometry_J5P0100.dgn 

78. Using the Feature Definition Toggle Bar set the Feature Definition to Island (New) 

(located under Linear ➔ Design ➔ Roadway) and toggle on Use Active Feature 

Definition. 

79. To help create the limits of the Island we are going to use the Single Offset Entire 

Element tool.  To do this select the OpenRoads Modeling Workflow ➔ Geometry Tab 

➔ Horizontal Section ➔ Offset and Tapers tools.  Select the NW Radius Return to 

off set the line toward the intersection. 

 

 

 

 

 

 

 

 

 

 

 

 

2017 Bentley OpenRoads Designer Best Practice – Terrain Modeling 

 

Offset:    -18 

Use Spiral Transitions:  No 

Mirror:     No 

Remove Offset Rule:   No 

Feature Definition:  Island (New) 

Name:    Island North 
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80. Repeat the Single Offset Entire Element tool for the SW Radius Return.  Offset the 

line toward the intersection. 

 

 

 

 

 

 

 

 

 

 

81. Repeat the Single Offset Entire Element tool, one more time, for the Big Horn baseline.  

Offset the line toward the West (away from the Big Horn centerline).   

 

 

 

 

 

 

 

 

 

 

82. To help round the corners of the Island we are going to use the Simple Arc tool.  To do 

this select the OpenRoads Modeling Workflow ➔ Geometry Tab ➔ Horizontal 

Section ➔ Arcs ➔ Arc Between Elements tools. 

 

 

 

 

 

 

 

Offset:    -18 

Use Spiral Transitions:  No 

Mirror:     No 

Remove Offset Rule:   No 

Feature Definition:  Island (New) 

Name:    Island South 

Offset:     17 

Use Spiral Transitions:  No 

Mirror:     No 

Remove Offset Rule:   No 

Feature Definition:  Island (New) 

Name:    Island Big Horn 

Trim Extend:   Both 

Radius:   4 feet 

Loop:     No 

Feature Definition:  Island (New) 

Name:    Island Noses 
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83. Next, we are going to Create a Complex Element around the island to make it one 

piece.  To do this use the Complex by Elements tool located under the OpenRoads 

Modeling Workflow ➔ Geometry Tab ➔ Horizontal Section ➔ Complex Geometry 

tools. 

 

 

 

 

 

 

 

 

a. Click each line/arc that makes up the island. Make sure each arrow points in the 

clockwise direction. (Manual option makes sure the elements all go in the correct 

direction). 

b. Accept the last element in a blank area with a Left Click. 

84. Reference within the Default 2D Model the following file:  

Terrain_ Proposed_J5P0100.dgn 

85. Open the Island’s Profile Model in Window 8. 

Method:   Manual 

Max Gap:   Use Default (0.0328) 

Feature Definition:  Island (New) 

Name:    Island 
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86. Next, we are going to create a Profile from the Island Terrain Model created earlier.  To 

do this use the Quick Profile from Surface tool located under the OpenRoads 

Modeling Workflow ➔ Geometry Tab ➔ Vertical Section ➔ Profile Creation tools. 

a. For Locate Reference Element, Left Click on the Island Complex Element. 

b. For Locate Reference Surface, choose the Island Terrain Model. 

The profile is automatically created. 

87. Left Click on the new Island profile (solid light green line), then name it Island 

Proposed and set it Active.  

 

88. Open the Cole/J5P0100/Roadway/data/Corridors_J5P0100.dgn 

89. Make sure you can see the new Island geometry, if you don’t see the Island, use the 

Level Display to visualize the Island elements, Level ➔ Roadway Safety. 

90. To help the Island draw to the Proposed “Island” Surface created back on Step 71, 

reference within the Default 2D Model the following file: 

Terrain_Proposed_J5P0100.dgn 

91. Open the Create Template tool by selecting the OpenRoads Modeling Workflow ➔ 

Corridors Tab ➔ Create Section ➔ Template tools. 

92. From the Corridor tools click on the Create Template tool 

Make sure the J5P0100.itl is open, if not, click File ➔ Open and select: 

Cole/J5P0100/Roadway/J5P0100.itl 

93. From the Components ➔ Curb and/or Gutter folder, copy Curb and Gutter Type B 

to the J5P0100 ➔ Ramps folder. 

94.  Double-click on the newly copied Curb and Gutter Type B to open it in the editor 

window. 
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95. Change the template origin to be the Curb_Surf_Flowline point and remove the 

constraints on the gutter point.  Simply Right-Click on the Curb_Surf_Flowline point 

and choose the Change Template Origin. 

 

96. Zoom to the left of the template and locate the Curb_Surf_Edge point. Double-click on 

this point. 

Set the Point Constraints to the following: 

 

 

 

 

 

 

 

 

 

 

Constraint 1:  Horizontal 

Parent 1: Curb_Surf_Flowline 

Value:   -2.5000 

Constraint 2: Project to Surface 

Parent 1: Any Direction 

Surface:  Island 



Intersection Design                      OpenRoads Designer Road 2  
 

38 Missouri Department of Transportation 12/23/25 

97. Run the Test when finished to see the Edge rise and fall with the surface. 

98. Close, then Save changes to the J5P0100.itl, and then Check-In. 

99. Select the Island geometry and bring up it’s heads up tools and select Apply Linear 

Template.   

 

100. Fill out the Apply Linear Template dialog as follows:   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

101. Press F4 to clear out the tool. 

102. Press F6 if the Default-3D window is not showing. 

At this point, the 3D model should show the new island.   

 

 

 

 

 

 

Lock to Start:    Check 

Lock to End:    Check 

Exterior Corner Sweep Angle: 5 

Mirror:     No 

Reflect:    No 

Template:            Curb and Gutter Type B 

Description:               Optional 

Feature Definition:   1-Final x 1 

Name      Island 
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Next, we will add a grass top to the island. 

103. Make the 3D view active, open the tool from Terrain Model tools, Create from 

Elements  

 

 

 

 

 

 

For Locate Element to Add, Left-Click the 3D line along the top inside edge of the curb 

(Curb_Surf_Back). 

 

 

 

 

 

 

 

 

 

104. For Locate Next Element, zoom out to see a blank area, Right-Click in the blank area of 

the Default 2D View. 

105. Left-Click to the prompts to accept all the values already entered in the dialog. 

 

 

 

 

 

 

 

 

 

 

Featue Type:  Boundary 

Edge Method:  None 

Feature Definition: Design Grassy Area 

Name    Island Grassy Area 
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After the island is placed, let’s look at the dynamic cross sections for the Ramp-4 Corridor. 

106. Left-Click on the Ramp-4 Corridor Grip and bring up the heads-up tools. 

 

107. Open Window 8 and left click in the window to display the Dynamic XS View.  

 

108. To clip the pavement area out below the Island let’s do the following: 

Select the SW and NW Radius Return Liner Templates and Add a Clipping Reference 

and select the Island Linear Template as the Reference. 
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Below is what the Ramp 4 Dynamic XS View should look like after the Clipping 

References have been applied: 
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Remove Grassy Island for Concrete Island 

109. First, we need to turn off the Triangles of the Grassy Area.  If we don’t the grassy area 

will still bleed through the newly placed pavement.  The Grassy Island Terrain Model 

resides withing the 3D view,  withing that view turn off the Triangles of the Island 

Grassy Area, 

110. Using the Apply Surface Template tool located under the OpenRoads Modeling 

Workflow ➔ Model Detailing  Tab ➔ 3D Tools Section ➔ Surface Template tools. 

   

a) For the Template select the following from the MoDOT section of the Template Library 

(itl):   

Components\Pavement - New\Pavement Only\Concrete\Concrete Pavement w/ Rock Fill 

Base. 

 

b) Do not Apply an External Clip Boundary 

c) Select Enable Linear Features 

d) Name the Surface Feature Concrete Island 

 

Notes: 

Apply External Clip Boundary will limit the area the Surface Template within a User 

selected closed area/element. 

 

Enable/Disable Linear Features will tell the program to either plot all the Mesh Layers of 

the Template (Enable), or just the Surface Mesh Layer (Disable).    

 

111. Edit the newly applied Surface Template. 
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112. When the Template window opens select the Active Template Tab.  Then open the 

Parametric Constraints folder and right-click on the Pavt_Surf_Conc_Depth and 

select Edit. 

 

113. Change the Default value to -4 inches by typing in -4/12 and then select OK. 

 

114. Select OK to the Editing Roadway Designer Template Drop dialog. 

115. Review the Dynamic XS Model for the updated Concrete Island.  
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Sight Visibility Tools 

116. Create a new dgn file named Site_Visability_J5P0100.dgn using the: 

  MoDOT_Roadway_Seed_2D.dgn seed file. 

 Note: This new file will hold all the Site Lines for this Project. 

117. Open the Coordinate System tool by selecting the OpenRoads Modeling Workflow 

➔ Utilities Tab ➔ Geographic Section. 

118. Select “From File” icon. 

 

 

 

 

 

 

119. Select the Terrain_Existing_J5P0100.dgn file in the data folder. 

120. Verify the settings.  

  

121. Reference in the following files within the Default 2D Model: 

Civil_Geometry_J5P0100.dgn 

Corridors_J5P0100.dgn 

Terrain_Existing_J5P0100.dgn 

122. Fit View, change the Annotation Scale to 1”=50’, and set the Existing Terrain as 

Active. 

123. Open View Attributes and turn-on Line Weights.  This will help with visualizing the 

Site Lines that are drawn in the 2D Default View. 

124. Select F6 key to open the Multi-Model Views. 
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Sight Visibility Tools 
 

Recently OpenRoads Designer added a Sight Visibility tools 

that analyzes a corridor and/or terrain to display what can be 

seen and not seen along a given line of sight. 

It uses the Stopping and Passing Sight Distance listed in AASHTO Green Book 2018 and 

MUTCD 2009. 

The Sight Visibility Tools can use a pre-defined Settings file to define the lengths of 

visibility.  For MoDOT Users that setting file is called: 

MoDOT-Sight Visibility Tables and Equations.xml 

The Sight Visibility Tool uses a Height of Eye Position of 3.50 feet and a Height of Object 

of 2.0 feet, as defined in the setting file. 
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MoDOT-Sight Visibility Tables and Equations.xml file. 
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Note: For the Non-Table Methods, when the AASHTO Stopping Sight Distance method is 

selected, the program uses the Equations 3-2, and 3-3 from the 2011 and 2018 AASHTO 

Green book.  In the 2018 edition these are in section “3.2.2 Stopping Sight Distance”. 
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125. Within the 3D view of Site_Visibility_J5P0100.dgn file, rotate to a top view.  Next, 

select the Sight Visibility tool by selecting the OpenRoads Modeling Workflow ➔ 

Terrain Tab ➔ Analysis Section ➔ Sight Visibility Tools. 

126. Define the dialog as follows and apply to the Big Horn Corridor and Existing Ground 

Terrain. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Settings File Name:   MoDOT-Site Visibility Tables and Equations 

Method:    Table 

Table Name:    AASHTO 2018 Stopping on Level Roadways 

Speed:     60 

Required Distance:   570 

Relaxed Distance:   570 

Locate Corridor:   Bighorn 

Locate Eye Control Alignment: Reset for Main Alignment 

Locate Object Control Alignment: Reset for Main Alignment 

Start Station:    Lock to Start 

End Station:    Lock to End 

Located Existing Ground:  J5P0100 Terrain Existing 
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127. Compare your results with Table Below: 

 
 

Note: Move Target to Achieve Visibility is defined as follows: The Object position's XY 

location is calculated like the Eye Position. However, for object position, the location is 

down range from the Eye Position along the Control Reference alignment a distance 

equal to the Required Distance. 

 

When Move Target is On a sight line for each Object Position Interval is analyzed until 

the Required distance is either achieved for that Eye Position or an intersection with a 

design or an existing terrain or mesh is found. In the case where an intersection is found 

and the Required Sight Distance has not been achieved, the analysis displays the last 

successful sight line for that eye position. 

128. In the 3D view, select and then delete the Sight Lines that were drawn in the previous 

step. 

129. Again, make sure 3D view is set to a TOP view. 

130. Next, select the Line of Sight tool by selecting the OpenRoads Modeling Workflow ➔ 

Terrain Tab ➔ Analysis Section ➔ Sight Visibility Tools. 
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131. Fill in the Sight Lines prompts/dialog when directed, working within in the 2D view: 

 

 

 

 

 

  

Note: You will need to datapoint both the Height of Eye and the Height of Object 

positions in the 3D view.  When you Data Point to Accept Design the Sight 

Triangle will be placed in the 3D View.  

 

 

 

 

 

 

Settings File Name:   MoDOT-Site Visibility Tables and Equations 

Method:    Radial 

Locate Corridor or Design Surface: Select the Bighorn Corridor 

Locate the Existing Surface:  J5P0100 Existing Ground 

Eye position:    Click somewhere within the Existing Ground Terrain 

Object position:   Click somewhere within the Existing Ground Terrain 

Stop Direction    Try to make a 360-degree solution. 
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132. In the Corridors_J5P0100.dgn 3D view, select and then delete the Sight Lines that 

were drawn in the previous step. 
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3D Drive Through 

133. Within the Corridors_J5P0100.dgn file select the 3D Drive Through tool by selecting 

the OpenRoads Modeling Workflow ➔ Corridors Tab ➔ Review Section. 

134. Select the 3D view, and then select the centerline of Big Horn Drive. 

135. Under General Controls Tab set the following settings: 

. 

136. Within the Advance Control Tab set the following settings: 
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137. Within Camera/Target Controls Tab set the following settings: 

 

138. Lastly, go back to the General Controls Tab and select the Play icon.  Utilize the 

Reverse and Rotate View controls. 
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139.  After using the 3D Drive Tool, you will notice a fish-eyed view within your 3D View, to 

turn that view effect off go into the View Attributes and deselect the “Camera” setting:  
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19.1 Group Exercise: Ramp Transition Layout 
 

Objective and Background Information 
 

The objective of this exercise is to demonstrate how the Power GeoPak Civil Tools can be used 

to create a profile for a ramp transition.  This is the area between the sections A-A and E-E in the 

following figure from Missouri Standard Plans for Highway Construction (203.41).  The profile 

will be applied along the ramp chain. 

 

 
 

As the figure indicates, the ramp is in Superelevation transition from the pavement cross slope at 

Section A-A to the Superelevation required for the beginning curve of the ramp at Section E-E.  

These two sections as shown in the standard plans are provided below. 

 

   
 

 

 

 

Before proceeding with the steps to create the profile, a decision needs to be made regarding the 

location of the break line between the mainline and ramp cross slopes.  According to the Design 

Standards group, the exact location of this break line at Section E-E is not set.  It can be located 

anywhere within the two-foot width of the ramp nose.  For the purposes of this exercise, it will 

be located on the ramp side of the nose and held at a constant offset of 20’ relative to the ramp 

chain from the ramp nose back to the point where this offset intersects with the mainline edge of 

pavement.  As a designer, you can determine its location for your project. 

 

The break in the slope between the 

mainline and the ramp can occur 

anywhere within these 2’ 
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Also needed is the Superelevation rate at the ramp nose, which is based on the design speed of 

the ramp and the radius of the curve.  The radius of the first curve in Ramp 2 is 1,041 feet. 

 

The relevant portion of the Superelevation table from Missouri Standard Plan 203.20F is shown 

below.  Based on emax = 8%, the ramp’s design speed of 40 M.P.H. and a rounded down radius of 

1030’, the Superelevation for the start of the ramp is 5.8%. 
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1) Open Osage\J5P0555\Plan_Overview_J5P0555.dgn 

a) Review project scope. 

 

2) Open Plan_J5P0555.dgn File. 

a) Attach Civil_Geometry_J5P0555.dgn 

b) Review plan geometry. 

 

Create template for Route 50 Corridor 
 

3) Create template for Route 50 Corridor 

a) Corridor Tab ➔ Template Tools ➔ Create Template 

b) Open the MoDOT Template Library (MoDOT.itl)  

 

The path to the MoDOT itl is as follows:  Documents\CADD_Standards\ORD 

Standards\Connect_Config\WorkSpaces\MoDOT\Standards\Template Library\ 

 

c) Save the MoDOT.itl to the Project’s data folder naming it J5P0555.itl  

d) Create a folder under the root directory named J5P0555. 

e) Under the J5P0555 folder create a Route 50 folder. 

f) Copy the following template into the Route 50 folder: 

▪ Templates ➔ Concrete Pavement w/ Shoulders ➔ A2 Shoulders Agg Base ➔ 

Concrete Pavement 4 Lane Divided w/ Agg Base Option 3 

g) Use the Delete Components option and remove the right outside Shoulder & 

Sublayers, Guardrail Widening, and End Conditions.  Do not delete Aggregate Base 

(See picture below). 

h) Delete three outside Aggregate Base points (See arrows below) 
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Note: The next few steps will add an auxiliary lane on the right side of the template.  The 

auxiliary lane is being added to provide the User a way to transition over a distance the 

Pavement Normal Slope of (2%) to the slope at the beginning of Ramp 2 (3.87%).  

 

4) In the Dynamic Settings, verify the Apply Affixes, are set with X & Y Steps = 0.1 

5) Add the following components to the right side of the template:   

a) Components ➔ Pavement – New ➔ Concrete Pavement w/ Shoulders ➔ A2 

Shoulders Agg Base ➔ Concrete Pavement 1 Lane w/ Agg Base Option 3 

b) End Conditions ➔ Combined ➔ 6:1 Fill or 6:1 Foreslope and Backslope Ditch 

 

 
 

6) Optional Step: Merge the common components. 

 

7) Edit the RT_Conc_T_EOP1 point. 

a) Toggle off the Horizontal Feature Constraint 

 

8) Edit the RT_Conc_T_EOP2 point. 

a) Toggle off the Superelevation Flag 

b) For the Slope Constraint Label enter in Auxiliary_Lane_Pavement_Slope 

c) Set the Horizontal Feature Constraint from the drop-down menu, select Linear ➔ 

Design ➔ Roadway ➔ EOP_New 

d) Set Horizontal Constraint distance to 0.001’ 

 

9) Edit the RT_AsphSurf_T_O_EOS1 point. 

a) Set the Horizontal Feature Constraint from the drop-down menu, select Linear ➔ 

Design ➔ Roadway ➔ EOS_New_Asphalt 
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10) Close, and Save the J5P0555.itl  

 

 

Create Route 50 Corridor 
 

11) Create Corridors_J5P0555.dgn using the MoDOT_Roadway_Seed_2D.dgn as the 

seed file. 

a) Set the Geographic Coordinate System from the Existing_Terrain_J5P0555.dgn 

b) Reference in the following dgn files: 

  Existing_ Terrain_J5P0555.dgn 

Plan_J5P0555.dgn 

Civil_Geometry_J5P0555.dgn 

c) Set Annotation Scale to 50 

d) Activate Existing Ground Terrain. 

e) Select the “Corridor Tab ➔ Create Section ➔ New Corridor” tool. 

f) Select the Route50 baseline (use the active profile) and name the corridor “Route50” 

g) Apply Roadway template 

o J5P0555 ➔ Route 50 ➔ Concrete Pavement 4 Lane Divided w/ Agg Base 

Option 3 

o From Station 445+30.94 R1 to Sta. 460+00 R1  

o Drop Interval of 5ft. 

▪ Note if the drop interval is too large the corridor might not see the 

Corridor Reference Elements. 

h) Select the “F6” key to open 3D view of model. 

 

12) Make the Default 2D view the active view in the Corridors_J5P0555.dgn. 

a) Turn off the display of the Corridors 3D file using the reference dialog. 

 

13) In the Route 50 Corridor add the four individual EOP_New lines from the 

Plan_J5P0555.dgn file as Corridor References. 
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14)  Add the following two Key Stations to the Route 50 Corridor  

a) 451+40.67 R1 (Just past beginning of Ramp 2) 

b) 453+55.67 R1 (Just before location of Shoulder Gore nose) 

 

Notes:  

• If a template drop does not cross an individual corridor reference element, the 

Corridor will not draw to that corridor reference element. 

• Use the Corridor Object Tool to verify the Key Stations were placed at the 

correct location.   

• You can also use the undo/redo buttons to help see the changes to your 

model. 

 

15) The shoulder width in the Ramp area is going to be narrower than the mainline.  In the 

Route 50 Corridor add the Complex EOS_New_Asphalt line from the Plan_ 

J5P0555.dgn file as Corridor References. 

 

Notes:  

• The shoulder is going to vary in width in certain areas of the project.  The 

plan shoulder element (EOS_New_Asphalt) will control the width in 

these areas   

 
 

16) Add the following Key Station to the Route 50 Corridor. 

a) 453+88.86 R1 (Just before location of Median Grass Gore nose) 

 

Notes:   

• If a template drop does not cross an individual corridor reference element, 

the Corridor will not draw to that corridor reference element. 

• Use the Corridor Object Tool to verify the Key Station was placed at the 

correct location. 

• You can also use the undo/redo buttons to help see the changes to your 

model. 
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Calculation of Ramp 2 Vertical Complex Element (Profile) 
 

17) Create Superelevation_ J5P0555.dgn using the MoDOT_Roadway_Seed_2D.dgn as 

the seed file. 

a) Set the Geographic Coordinate System from the Existing_Terrain_J5P0555.dgn 

b) Reference in Civil_Geometry_J5P0555.dgn 

c) Set Annotation Scale to 50 

d) Review the undivided non-spiraled Superelevation runoff diagram below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

18) Select Create Superelevation Section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Feature Definition:  Superelevation 

Feature Name:   Ramp 2 Superelevation 

 

Section Name:   Ramp2 

Alignment:   Ramp2 

Start Station:   Lock to Start 

Stop Station:   Lock to End 

Minimum Transition Length:  1000 

Lane Creation Method: Manual 
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Note:  If two Superelevation Sections are created, delete second Superelevation Section, and 

then extend the First section to the end of the Ramp 2 alignment. 

19) Select Create Superelevation Lanes and create the following two Superelevation Lanes. 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

20) Select Calculate Superelevation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Lane Name:   6-18FT 

Type:    Primary 

Side of Centerline:  Left 

Inside Edge Offset:  6’ 

Width:    12’ 

Normal Cross Slope:  2.00% 

Rules File Name:   MoDOT_Superelevation_Rules_File.xml 

e Selection:   8%  

L Selection:   MoDOT – AASHTO 2018 Eq. 3-23 and Table 3-16a 

Design Speed:   40 mph 

Pivot Method:   Right Edge 

Open Editor   Yes 

Lane Name:   0-6FT 

Type:    Primary 

Side of Centerline:  Left 

Inside Edge Offset:  0’ 

Width:    6’ 

Normal Cross Slope:  2.00% 
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Below is a view of the Superelevation Editor for Ramp 2. 

 

 
 

21) Delete the 6-18ft Lane. 
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22) Verify your result by running a Superelevation Calculation Report and comparing with 

the results listed below: 
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23) Next calculate the transition distance of the Mainline Pavement in the transition area 

before the PC location of the Ramp2 Curve. 

 

x = (150) (2%)/ (5.8%)  = 52’ 

 

Distance from C-C section to PC = L - (L/3) - x = (150’) - (150’/3) – 52’ = 48’ 

 

Note: This is the distance the Auxiliary Lane will have to transition from 2% (Mainline 

Slope) to a 3.87% (Ramp 2 Slope) at the PC location of the Ramp. 

Open the Corridors_J5P0555.dgn. 

 

24) For the next step select the Corridor Views ➔ Open Cross Section Model and verify 

the Route 50 Mainline Ramp Pavement is transitioning downward.  Use the Place 

Temporary Dimension Line to verify the slopes of the mainline pavement. 

 

25) Apply the following Parametric Constraint. 

a) Route50 station value at start location of Ramp2 = Sta. 451+40.67 

b) Transition Start Station = Sta. 451+40.67 - 48’ = Sta. 450+92.67 

 

 

Start:   450+92.67 R1 

Stop:   451+40.67 R1 

Constraint Label: Auxiliary_Lane_Pavement_Slope 

Start Value:  -2.00% 

Stop Value:  -3.87% 
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Create templates for Ramp 2 Corridor 
 

26) Create template for Ramp2 Corridor 

a) In the Corridor Modeling Tab select the Create Template icon 

b) Open the J5P0555.itl 

c) Navigate to the J5P0555 and Create a new folder called Ramp 2 

d) Right click on Ramp 2 folder and select New > Template 

e) Name the Template Ramp 2 

f) In the Dynamic Settings dialog, verify the Apply Affixes (LT_ , RT_ ), with X & Y 

Steps = 0.1 

g) Use the following Components and End Conditions to create the Ramp2 Template: 

 

 
Template Components: 
 

Left Side 

        

Concrete Pavement 1 Lane w/ Agg Base Option 3 

 

Right Side 

 

A2 Shoulder Asphalt Option 3 w/ Agg Base  

 

 
Template End Conditions: 
 

Left Side       

 

Fill Slope (6:1) 

 

Right Side 

 

6:1 Fill or 6:1 Forslope and Backslope Ditch 

 

*Notes 
 

a) Concrete Pavement 1 Lane w/ Agg Base Option 3 is located in the following location: 
Components\Pavement - New\Concrete Pavement w/ Shoulders\A2 Shoulders Agg Base\ 

b) A2 Shoulder Asphalt Option 3 w/ Agg Base is located in the following location: 

Components\Shoulders\Asphalt Adjacent to Concrete Pavt w/o Curb\ 

c) 6:1 Fill or 6:1 Forslope and Backslope Ditch is located in the following location: 

End Conditions\Combined\ 

d) Adjust pavement slope to be 2% going up from baseline. 

e) If not already done so, adjust the shoulders to follow the pavement slope using a Vector 

Offset constraint. 

f) Check Priorities on End Conditions using the “TEST” button. 

 

Template Origin 
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Next, we will need to create another Ramp2 template for the area where the ramp and 

mainline butt up to each other. 

 

27) Copy and paste the “Ramp2” Template located in the Ramp2 folder. 

 

28) Name new template “Ramp2 - No LT Shoulder”. 

 

29) Use the Delete Components option and remove the left outside Shoulder & Sub layers, 

and End Conditions.  Do not delete Aggregate Base (See picture below). 

 

30) Delete two Aggregate Base points (See arrows below) 

 

 
 

31) Close and save. 
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Create Ramp 2 Profile 
 

32) Open the J5P0555_Superelevation.dgn file and review superelevation sections. 

a) Verify slope at PC location is 3.87% 

b) Verify slope at Max Super is 5.80%  

 

33) Open the J5P0555_Civil_Geometry.dgn file. 

a) Within the Default 2D View reference in the Corridors_J5P0555.dgn file. 

 

34) Open the Profile Model for the Ramp2 Alignment. 

 

35) From the Route50 edge of pavement, project the superelevation slope down to the 

Ramp2 baseline.  Select the Geometry Tab ➔ Vertical Geometry Section ➔ Element 

Profiles Tools ➔ Profile by Variable Slope from Element. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Feature Definition:  Geometry Scratch 

Name:    RTE 50 EOP Projected Slope 

 

Slope Relative to Target: Check 

 

Slope Style:   Linear 

Plan Element:   Ramp2 Baseline 

Reference Element:  EOP_New line between Ramp 

and Mainline 

Start Distance:   6+10.01 (Ramp2 Sta. 0+00.00) 

Start Value:   -3.87% 

Stop Distance:   6+81.97 (Ramp2 D-D Section)  

Stop Value:   -5.80% 

Vertical Offset:  0.00’ 
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Note: The profile created in the previous step should look like the profile below.  

Because the Reference Element (Mainline EOP) had 90-degree edge near the beginning 

of Ramp2, a kink is produced in the resulting profile.  The 90-degree edge was 

 created because the EOP_New plan line is being targeted with Corridor Reference.  

 

 
   

36) To create a profile without a kink, remove the EOP_New Corridor Reference nearest the 

PC of the Curve. 

a) Open the Corridors_J5P0555.dgn file 

b) From the Corridor heads up tools, select “Remove Corridor Reference”  

 

37) Open the J5P0555_Civil_Geometry.dgn file. 

 

38) Open the Profile Model for the Ramp2 corridor. 

 

39) Delete first projected profile. 
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40) From the Route50 Edge of Pavement, project the superelevation slope down to the 

Ramp2 baseline.  Select the Geometry Tab ➔ Vertical Geometry Section ➔ Element 

Profiles Tools ➔ Profile by Variable Slope from Element. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: If you add EOP_New Corridor Reference back in the kink will show back up.  The profile 

is dynamically linked to the EOP profile. 

 

41) Open the Route50 Profile model and verify the profile grade at Sta. 451+40.61 is 4.00% 

 

42) Reopen the Ramp2 Profile model. 

 

43) Using the Profile Line Between Points tool, located under the Geometry Tab ➔ 

Vertical Geometry Section ➔ Line Tools, place a 4% slope before the Projected 

Ramp2 profile. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Feature Definition:  Geometry Scratch 

Name:    RTE 50 EOP Projected Slope 

 

Slope Relative to Target: Check 

 

Slope Style:   Linear 

Plan Element:   Ramp2 Baseline 

Reference Element:  EOP_New line between Ramp 

and Mainline 

Start Distance:   6+12.74 (Ramp2 Sta. 0+00.00) 

Start Value:   -3.87% 

Stop Distance:   6+72.71 (Ramp2 D-D Section)  

Stop Value:   -5.80% 

Vertical Offset:  0.00’ 

 

 

Feature Definition: EOP_New 

Name:   Match RTE 50 Profile Slope 

 

Slope:   4% 
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44) Once again project the superelevation slope down to the Ramp2 baseline, but this time  

from the Route50 Edge of Shoulder. 

 

Select the Geometry Tab ➔ Vertical Geometry Section ➔ Element Profiles Tools ➔ 

Profile by Variable Slope from Element. 

 

Project down from the midpoint of the shoulder line to right edge (See below). 

 

 
 

To understand how Start and Stop distances of this step relates to the station limits and 

plan geometry, review the notes in the Plan_J5P0555.dgn file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Feature Definition:  Geometry Scratch 

Name:    RTE 50 EOS Projected Slope 

 

Slope Relative to Target: Check 

 

Slope Style:   Linear 

Plan Element:   Ramp2 Baseline 

Reference Element:  EOS_New line between Ramp 

and Mainline 

Start Distance:   8+49.46 (Ramp2 Sta. 2+28.79) 

Start Value:   -5.80% 

Stop Distance:   8+66.1476 (Ramp2 Sta. 2+45.18)  

Stop Value:   -5.80% 

Vertical Offset:  0.00’ 
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45) Within the Feature Definition Toggle Bar set the Feature Definition to 

MoDOT_Baseline_Proposed.  Also, toggle on “Use Active Feature Definition”. 

  

  
 

46) Using the Parabola from Element tool, located under the Geometry Tab ➔ Vertical 

Geometry Section ➔ Curve Tools ➔ Profile Curve from Element Sub-Tools, place a 

vertical curve from the start of the Projected profile to the end.   

 

a) After starting the tool, the “Locate Element” will be the 4% Profile Line.   

b) After placing the start point at the beginning of the Projected Profile, define the 

endpoint of the vertical curve by Accu-Snapping to the right endpoint of the 

second Projected Profile.   

c) When asked to Trim, select the “None” option. 

 

Note: You can use Civil AccuDraw to help start the profile at Sta. 0+00.00 

 

47) The last VPI for the Ramp2 profile will be where the ramp chain crosses the Big Horn 

crossroad gutter line.  This point is offset 18.5’ from the crossroad centerline.  The 

elevation of the crossroad at this point and corresponding ramp station have already been 

determined below.  Based on this, the last VPI at the end of the profile should use the 

following VPI station and elevation.  

 

 

 

 

Using the Tangent Profile Line to Element tool, located under the Geometry Tab ➔ 

Vertical Geometry Section ➔ Lines Tools ➔ Profile Line to Element Sub-Tools, 

select the previously placed profile line, and using AccuDraw and its “Z” Mode place the 

endpoint at Sta. 16+36.81 at an Elevation of 763.92.  When asked to Trim, select the 

“Back” option. 

 

48) Delete both the 4% Profile line located before the PC Point and the two Projected 

Profiles. 

 

49) Join the two profile elements using the Vertical Geometry Profile Complex By 

Elements, naming the profile Ramp 2 Proposed (If the tool does not let you Complex 

the profile elements make sure you make sure you delete all the elements in the previous 

step). 

 

50) Set the Ramp2 Proposed profile as active.  

 

 

 

 Station   Elevation 

16+36.81     763.92 
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51) Run the Vertical Alignment Report on the Ramp 2 Proposed profile. 

 

52) Open the Corridors_J5P0555.dgn file. 

 

53) Reapply the EOP_New element located just before the beginning of Ramp 2 as a 

Corridor Reference for the Route50 corridor. 
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Create Ramp2 Corridor 

 
54) Create a new corridor by selecting Corridors Tab ➔ New Corridor. 

 

55) Select the Ramp2 baseline and name the corridor “Ramp2”. 

 

56) Apply Roadway template. 

a) J5P0555\Ramp2\Ramp2 - No LT Shoulder 

b) From Station 0+00.00 R1 to Sta. 2+45.18 R1 

c) Drop Interval of 1ft. 

 

57) Apply Roadway template. 

a) J5P0555\Ramp2\Ramp2 

b) From Station 2+45.19 R1 to Sta. 15+00 R1 

c) Drop Interval of 10ft. 

 

58) From the Route 50 Corridor clip out the Ramp2 Corridor. 

 

59) If needed select the “F6” key to open 3D view of model. 

 

60) Within the Default 2D View, reference in the J5P0555_Superelevation.dgn file. 

a) Assign Superelevation to the Ramp2 Corridor. 

b) The slope of the pavement before the shoulder nose will be controlled by the 

Route 50 Edge of Pavement using a Point Control.   

c) The slope of the pavement after the shoulder nose will be controlled by the 

Superelevation shape.  Therefore, adjust the Priority of the Superelevation Point 

Control to be greater than 1. 

d) In the Reference Dialog turn off the Display of the Superelevation.dgn. 
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61) To make the Ramp2 pavement draw up to the EOP of the mainline set the following 

Point Control:  

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

62) To make the Ramp2 pavement draw up to the EOS of the mainline (in the area of the 

shoulder median), set the following Point Control: 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Start Station:  0+00 

Stop Station:  2+12.42 (just shy of the 

shoulder nose) 

Description:  Draw to Mainline EOP 

Point:   LT_Conc_T_EOP 

Mode:   Both 

Control Type:  Corridor Feature 

Corridor:  Route50 

Reference Feature: RT_Conc_T_EOP2 

Priority:  1 

Horz. & Vert. Offset: 0 

Start Station:   2+12.44 

Stop Station:   2+45.18 

Description:   Draw to Mainline EOS 

Point:    LT_Conc_T_EOP 

Mode:    Both 

Control Type:   Corridor Feature 

Corridor:   Route50 

Reference Feature:  RT_AsphSurf_T_O_EOS1 

Priority:   1 

Horz. & Vert. Offset:  0 
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63) You will notice that after the point Controls were applied that the Ramp Pavement at the 

start of the alignment now does not draw correctly.  To fix this will apply a Key Station. 

 

 
The first two Template Drops for Ramp 2 are both solving for the Route 50 EOP.  The first 

Template Drop is solving for the widened Axillary Lane EOP, and the Second Template Drop is 

solving for the normal Route 50 EOP. 

 

To fix this we will introduce a Key Station just after the Start of the Ramp 2 start location at 

Station 0+00.01 and adjust the Template Drop Start Station to 0+00.004. 
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64) To make the Ramp 2 pavement model correctly, the Route 50 shoulder indicated by the 

red arrow needs to be removed. 

 

Because there is shoulder width in the area indicated by the red arrow, the pavement of 

Ramp 2 is not allowed to draw to the Route 50 Edge of Shoulder near the Shoulder 

Median Nose. 

 

 

65) In the Route 50 Template modify the RT_AsphSurf_T_O_EOS1 point and rename the 

Horizontal Constraint Label from Shldr_Asph_A2_Width to 

RT_Outside_Shldr_Asph_A2_Width.   

 

Notes:  

 

• In the next step we will use a Parametric Constraint to set the Route 50 Shoulder 

Width to zero in the area above. 

 

• The benefit to using a Parametric Constraint is because it’s a lower level of 

control than the Feature Constraint.  Therefore, the User should define a general 

station range to apply the Parametric Constraint around the shoulder gore area and 

let the Plan Element of the Feature Constraint exactly define the limits of the 

shoulder gore nose. 

 

• See next page for Template Point Hierarchy of Control. 
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66) Apply the following Parametric Constraint to the Route 50 Corridor to set the 

Shoulder Width to zero around the Shoulder Nose. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Start:   453+40.00 R1 +/- 

Stop:   453+70.00 R1 +/- 

Constraint Label: RT_Outside_Shldr_Asph_A2_Width 

Start Value:  0.00 

Stop Value:  0.00 
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67) Add the EOP_New line that transitions from an 18’ offset to a 20’ offset as corridor 

references in the Ramp2 Corridor.  The EOP line is near the grass gore point (see Blue 

Arrow below).  

• Next, you will need to change the LT_Conc_T_EOP point’s Horizontal Feature 

Constraint in both the Ramp 2 Template Drops from Linear ➔ Design ➔ 

Roadway ➔ DNC to Linear ➔ Design ➔ Roadway ➔ EOP_New  

 

 
 

68) Edit the J5P0555\Ramp2\Ramp2 template and modify the Horizontal Constraint for the 

LT_Conc_T_EOP point to a width of 18’. 

 

69) To help with the situation below, within the Ramp 2 Corridor, Target Alias the Route 50 

Corridor. Also add the terrain as the secondary target. 
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Create Special Ditch - Drawing the Ditch Foreslope to a Alignment and 

Profile 
 

70) In the Civil_Geometry_J5P0555.dgn create following Ditch Alignment and Profile. 

a) Use the Horizontal Geometry Tool Complex By PI to place a line with a Feature 

Definition of Linear ➔ Design ➔ Drainage ➔ Special_Ditch_Right at the 

following locations:   

▪ Note: use Civil AccuDraw to place 

line accurately along the Route50 and 

Ramp 2 Alignment. 

▪ Use a radius of 200’ 

▪ Name the ditch alignment: Special 

Ditch 

 

 

 

 

b) Open the Special Ditch Profile View.  Use the Vertical Profile Line Between 

Points Tool to place a profile with the following VPIs: 

 

▪ Note: use Civil AccuDraw to place profile 

accurately along the Special Ditch Alignment. 

▪ Name this profile: Special Ditch Proposed 

▪ Make the profile Activate 

 

71) In the next few steps, we are going to apply a Point Control that will control how the 

Ditch Foreslope Bottom point (RT_Dtch_Frslp_1_B ) behaves. Currently within the 

Ramp2 Corridor, all the right End Conditions are only solving for a Fill Slope.   

Note: For the RT_Dtch_Frslp_1_B to be controlled with a Point Control the Right Ditch 

End Condition must be solving somewhere in the corridor.   

In other words, with a Point Control, to select and control the 

RT_Dtch_Frslp_1_B point, a right cut/ditch must be drawing somewhere in the 

corridor.  If a ditch is not drawing, the ditch foreslope point will not be listed as an 

available point to control in the Point Control dialog.     

Open the Corridors_J5P0555.dgn and within the first Ramp 2 Corridor Template 

Drop change the Ditch Foreslope Slope constraint to a -50% slope. 

 

 

 

 

 

 

Station Offset Chain 

   

445+30.94 120 Route50 

448+70.00 120 Route50 

449+50.00 150 Route50 

1+00 90 Ramp2 

5+00 70 Ramp2 

10+00 100 Ramp2 

Station Elevation 

0+00 688.00 

15+75.75 704.00 
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72) In the Corridors_J5P0555.dgn file create the following Point Controls to have the ditch 

bottom foreslope point draw the special ditch. 

Route 50 Corridor:  

 

 

 

 

 

 

 

 

 

Ramp 2 Corridor: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Start Station:    Beginning of Alignment 

Stop Station:    451+40.67 R1 (Start of Ramp 2) 

Control Description:   Draw to Special Ditch Alignment and Profile 

Point:     RT_Dtch_Frslp_1_B 

Mode:     Both 

Control Type:    Linear Geometry 

Plan Element:    Special Ditch 

Profile Element:   Special Ditch Proposed 

Use as Secondary Alignment:  Yes 

Priority:    1 

Horz. & Vert. Offset:   0 

Start Station:    Beginning of Alignment 

Stop Station:    15+00 R1 

Control Description:   Draw to Special Ditch Alignment and Profile 

Point:     RT_Dtch_Frslp_1_B 

Mode:     Both 

Control Type:    Linear Geometry 

Plan Element:    Special Ditch 

Profile Element:   Special Ditch Proposed 

Use as Secondary Alignment:  Yes 

Priority:    1 

Horz. & Vert. Offset:   0 
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73) Open the Route 50 Dynamic Cross Section Model View.  Place Temporary Dimension 

Lines along the Ditch Foreslope.  You should notice that the slope is changing from 

section to section because the Bottom Ditch Foreslope point must hit the Special Ditch 

Alignment and Profile.  In the next few steps, the parameters will change such that the 

slope remains constant, and the ditch will follow the ditch elevation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Notes:  When placing a Temporary Dimension Line and you’re having troubles selecting a 

location on the template, you might try the following: 

a) Delete the Dynamic XS View, by Right Clicking and Holding in the Cross Section 

view, select View Controls ➔ Delete Dynamic XS View. 

b) If you used the “Locate Station via Datapoint” option, make sure the Dynamic Cross 

Section you’re viewing is on a template drop location and not in between two drops. 
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Create Special Ditch - Drawing to a Ditch Profile while holding Constant the 

Ditch Foreslope  

Point Controls work by replacing the constraint that most closely matches the point 

control.  Example: If a point has a Horizontal and Slope Constraint, a Vertical Control 

will replace the Slope Constraint, but if the point has a Vertical Constraint and a Slope 

Constraint, the Vertical Control would replace the Vertical Constraint.  If the constraints 

are the same (Slope-Slope for instance), the Second constraint will be replaced. 

 

 

74) To draw to Ditch profile some points in the Ditch Component need to be redefined in all 

three template drops on the south side of the project. 

a) Edit the RT_Dtch_Frslp_1_B point. 

▪ Adjust the slope to -25.00% 

▪ Change the Horizontal Constraint to a Vertical Constraint. 

 

b) Edit the RT_Dtch_Bkslp_1_T point. 

▪ Adjust the slope to 25.00% 

 

 

 

 

 

Tips and Tricks for Roadway Designer - Bentley 2009 Roads and Bridges 

Conference 



Ramp Transition Layout                GEOPAK Road 2 

30 Missouri Department of Transportation 12/23/25 

75) In the Route 50 and Ramp 2 Corridors, edit the Special Ditch Point Controls by 

changing the Point Control Mode from Both to Vertical. 

 

 

 

 

 

 

 

 

 

 

 

 

Note: There is one section off the Route 50 Corridor that does not solve for a Ditch after 

applying the adjusted Point Controls.  To make that section solve as a ditch, the User 

could move the Special Ditch Profile down one foot at the start the profile. 
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Note:  Point Control Recommendations from Kevin McDonald at Bentley 

• I advise all Users not to use point controls on the last point of an end condition.  End 

conditions need the freedom to seek their targets successfully, and typically, extending 

the end condition out to meet the target is typically last, even after point controls are 

applied. 

• Instead of using point controls on the last point of end conditions, a higher priority end 

condition can be created that seeks the linear geometry.  So, for example, in the station 

range from 138+97.04 to 139+78.05 right, we should not use point controls on the points 

“Fill_Slope_1_B_R” and “Fill_Slope_2_B_R”, we should instead create Priority 1 End 

Conditions that seek the Linear Geometry elements (or add an end condition exception 

that does it).   If they find their target, they will construct a point along the linear, if they 

fail, they will move to the next priority end condition that will seek the Terrain. 

• The question sometimes gets raised… “Why does it work sometimes?”  As in this case, it 

seems to work OK on some stations, but it is now failing.  The answer I give is because 

there are lot of factors that affect the order end conditions and point controls are 

processed, so it can work sometimes, but not dependably.  Using End Conditions to seek 

targets is the dependable method. 

 

In Summary: 

It’s good practice to never to use a Point Control on the last point of an End Condition.  

The main reason is that the end condition needs the freedom on the last point to 

successfully find its target.  Point controls can possibly move the last point such that it 

doesn’t find the target which can cause the entire end condition to fail.  (There are cases 

where it will work out OK, but it is just safer never to do it.) 

If you have some geometry that will fully control the last point of an end condition, just 

seek that geometry with an End Condition.  For example, if I have a geometry 

representing the Horizontal and Vertical location of where I want a slope to tie, I can 

model it with an end condition that seeks the horizontal, then attach another end 

condition that seeks the vertical.  If you mark the first point as Do Not Construct, it will 

draw the slope from the start point to the tie point. 

        Kevin McDonald 

        Bentley Systems, Inc. 
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19.1 Things you might learn new in this Chapter: 

 

• Class C Excavation 

• Requesting Soil Borings 

• Superelevation Lanes 

• Importing Rock Borings 

• Extending a Rock Surface 

• Reading a Soil Survey 

• What is Slope of Repose? 

• Template Creation 

o Tracing Rock and Ground Surfaces 

o Point “Value Equations” 

o Display Rules 

▪ AND, OR, and NOT conditions 

o Parent Components 

o Benching Components 

o Automatic Point Merging involving Multiple Points. 

o End Condition Branching off other End Conditions 

o End Condition Priorities vs Display Rules 

o Feature Name Override (Point and Component) 

• Modifying Corridor Feature Definitions 

• Creating Complex Terrain Models 

• Apply Terrain Elevations to COGO Points using the Modify Points tool 

• Cross Section Navigator 
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19.2 Determine Boring Locations  

1) Open the Cole\J5U0441G\Project_Summary_J5U0441G.dgn. 

a) Review the project limits. 

 

2) Open the Cole\J5U0441G\ Typical_Sheet_Scale-10_J5U0441G.dgn. 

b) Review the Preliminary Typical Section. 

19.2.1 Create Route 179 Corridor 

3) Open the Project Template Library J5U0441G.itl using the Create Template tool located 

within the OpenRoads Modeling Workflow ➔ Corridors Tab ➔ Create Section 

 

a) Review the 4 Lane Asphalt w/ Type C Barrier template in the J5U0441G 

folder.   

b) Close Template Library. 

4) Create a new file named Corridors_Preliminary_J5U0441G.dgn 

a) Use the MoDOT_Roadway_Seed_2D.dgn as the seed file. 

b) Set the Geographic Coordinate System from the 

Terrain_Existing_Ground_J5U0441G.dgn 

c) Reference in the following dgn files: 

o Terrain_Existing_Ground_J5U0441G.dgn 

o Civil_Geometry_J5U0441G.dgn 

d) Set Annotation Scale to 50 

e) Activate Existing Ground Terrain. 

 

5) Select the “Corridor Tab ➔ Create Section ➔ New Corridor” tool. 

a) Use a Corridor Feature of 1-Final x 1 

b) Select the Route 179 baseline (use the active profile) and name the corridor 

Rte179. 

c) Apply the following Roadway template: 

 J5U0441G ➔ 4 Lane Asphalt w/ Type C Barrier 

d) Apply Stationing from 62+00 R1 to Sta. 142+00 R1  

e) Use a Drop Interval of 100ft. 

 

6) Select the “F6” key to open 3D view of model. 
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19.2.2 Creating Superelvation 

7) Create a new file named Superelevation_J5U0441G.dgn using the 

MoDOT_Roadway_Seed_2D.dgn as the seed file. 

a) Set the Geographic Coordinate System from the 

Terrain_Existing_Ground_J5U0441G.dgn 

b) Reference in the following dgn files: 

o Civil_Geometry_J5U0441G.dgn 

8) Set Annotation Scale to 50 

 

9) Select Create Superelevation Section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  If more than one Superelevation Section is created, delete the extra Superelevation 

Section(s), and then extend the First section to the end of the Route 179 alignment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Name:     179 

 

Locate Corridor or Alignment: Select CL Alignment 

 

Start Station:    Lock To Start 

End Station:    Lock To End 

Minimum Transition Length:   10,000 

Lane Creation Method:  Manual 

 

Feature Definition:   Superelevation 

Feature Name:    SE 179 
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10) Review the Typical Section below, remember with Superelevation the Designer must 

account for the concept of Number of Lanes Rotated. Our MoDOT Superelevation 

Settings file considers a Half a Lane Rotated as being a Lane Width from 0-6ft, and a 

Full Lane Rotated is being a Lane Width greater than 6ft up to 12ft.  With our Typical 

Section below we have 2-1/2 Lanes Rotated (6ft Lane) + (12ft Lane) + (12ft Lane). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11) Select Create Superelevation Lanes and create the following two Superelevation Lanes. 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Lane Name:   0-6FT 

Type:    Primary 

Side of Centerline:  Left 

Inside Edge Offset:  0’ 

Width:    6’ 

Normal Cross Slope:  -2.00% 

Lane Name:   0-6FT 

Type:    Primary 

Side of Centerline:  Right 

Inside Edge Offset:  0’ 

Width:    6’ 

Normal Cross Slope:  -2.00% 
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Lane Name:   18-30FT 

Type:    Primary 

Side of Centerline:  Left 

Inside Edge Offset:  18’ 

Width:    12’ 

Normal Cross Slope:  -2.00% 

Lane Name:   6-18FT 

Type:    Primary 

Side of Centerline:  Right 

Inside Edge Offset:  6’ 

Width:    12’ 

Normal Cross Slope:  -2.00% 

Lane Name:   18-30FT 

Type:    Primary 

Side of Centerline:  Right 

Inside Edge Offset:  18’ 

Width:    12’ 

Normal Cross Slope:  -2.00% 

Lane Name:   6-18FT 

Type:    Primary 

Side of Centerline:  Left 

Inside Edge Offset:  6’ 

Width:    12’ 

Normal Cross Slope:  -2.00% 
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12) Select Calculate Superelevation and use setting below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13) Review within the Editor, that the Superelevation values are same for all the Left Lanes, 

and that all the  Superelevation values are same for all the Right Lanes. 

 

14) Run a Superelevation Report and verify the Number of Lanes Rotated is equal to 2.5 

 

Use the Superelevation Calculations.xsl report. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Rules File Name:   MoDOT_Superelevation_Rules_File.xml 

e Selection:   8%  

L Selection:   MoDOT – AASHTO 2018 Eq. 3-23 and Table 3-16a 

Design Speed:   60 mph 

Pivot Method:   Crown 

Open Editor   Yes 
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15) Because our Route 179 Template has two Pavement components (32ft wide each), we 

only need two Superelevation Lanes, one on the Left side of CL and one on the Right 

side of CL.  

 

Delete two of the three lanes from each side of the Centerline. 

 

 
 

16) Reopen the Corridors_Preliminary_J5U0441G.dgn 

 

17) Attach and then Apply the Superelevation to the Route 179 Corridor. 

 

Note: Depending on which Superelevation Lanes you delete in a previous step, the 

Superelevation Lane name listed could vary from User to User.   

 

 

 

18) Open the Cross Section Model and verify Superelevation is applied to the Route 179 

Corridor. 

19) Within View 1, Default turn-off the Display of the Superelevation_J5U0441G.dgn file. 

 

 

Left Lane 

Right Lane 
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19.3 Create Preliminary Cross Sections Sheets: 

20) Create a new file named Named_Boundary_179_Preliminary_XS_J5U0441G.dgn  

a. Use the MoDOT_Roadway_Seed_2D.dgn seed file. 

b. Set the Geographic Coordinate System using the settings in the following file: 

   Terrain_Existing_Ground_J5U0441G.dgn 

c. Reference in the following dgn files: 

    Civil_Geometry_J5U0441G.dgn 

   Corridors_Preliminary_J5U0441G.dgn 

   Terrain_Existing_Ground_J5U0441G.dgn 

d) Set Annotation Scale to 50 

e) Activate Existing Ground Terrain. 

19.3.1 Creating the Named Boundary 

21) IMPORTANT: Enable both the 2D and a 3D view by selecting the F6 key (or the tool 

will create the Named Boundaries and NOT the sheet and drawing models. The sheets 

may be created at a different time using the Named Boundaries Manager) 

22) In this next step we are going to be placing Named Boundary’s to indicate where we want 

to cut cross sections.  We are going to show you two ways to open the Named Boundary 

Tool. 

The first way to access the Named Boundary tool is to select the OpenRoads Modeling 

Workflow ➔ Drawing Production tab ➔ Named Boundary tool.  

 

 

 

 

 

This method unfortunately does not set up the Named Boundary Attributes. 
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The second way to open the Named Boundary tool is to Right-Click in a blank area in the 

Default 2D window (typically View #1, Default) 

 

The benefit of using the right click option is that ORD will automatically set up the 

Attributes for the Named Boundary. 

Before 

 

After 
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23) After the Place Named Boundary dialog opens, select the Civil Cross Section icon 

 

a) Set the following Dialog Settings:  

 

b) Once the dialog has been filled out then Accept/Reject to either place the named 

boundary or end the tool. 
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24) When you Accept the dialog input with the Show Dialog checked on there will be 

another dialog that opens (see below). 

Change the Annotation Group to the XS Annotation - No Grid option.   
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In the next few steps, we are going to use the Cross Section Navigator tool to review the 

cross sections to identify the flat bottom ditch location.  Typically, borings are done at the 

back of ditch location. 

25) Open the Multi-Model Views, and then also open View 8  

26) Select the Drawing Production Tab ➔  Review Section ➔ Cross Section Navigator. 
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27) Below is a list where boring should be requested: 

 

 

 

 

 

Station Left 72 feet CL Right 72 feet Station Left 72 feet CL Right 72 feet

62+00 Yes Yes Yes 103+00 No Yes Yes

63+00 Yes Yes Yes 104+00 Yes Yes Yes

64+00 Yes Yes Yes 105+00 Yes Yes Yes

65+00 Yes Yes Yes 106+00 Yes Yes Yes

66+00 Yes Yes Yes 107+00 Yes Yes Yes

67+00 Yes Yes Yes 108+00 Yes Yes Yes

68+00 Yes Yes Yes 109+00 No Yes Yes

69+00 Yes Yes No 110+00 No No No

70+00 Yes Yes No 111+00 No No No

71+00 Yes Yes No 112+00 No No No

72+00 Yes Yes No 113+00 No No No

73+00 Yes Yes No 114+00 No No No

74+00 No No No 115+00 No No No

75+00 No No No 116+00 No No No

76+00 No No No 117+00 Yes Yes No

77+00 No No No 118+00 Yes Yes No

78+00 No No No 119+00 Yes Yes Yes

79+00 No No No 120+00 Yes Yes Yes

80+00 No No No 121+00 Yes Yes Yes

81+00 No No No 122+00 No Yes Yes

82+00 No No No 123+00 No Yes Yes

83+00 No No No 124+00 No No No

84+00 No No No 125+00 Yes Yes Yes

85+00 No No No 126+00 Yes Yes Yes

86+00 No No No 127+00 Yes Yes Yes

87+00 Yes Yes Yes 128+00 Yes Yes Yes

88+00 Yes Yes Yes 129+00 Yes Yes Yes

89+00 Yes Yes Yes 130+00 No Yes Yes

90+00 Yes Yes Yes 131+00 No Yes Yes

91+00 Yes Yes Yes 132+00 No Yes Yes

92+00 No Yes Yes 133+00 No No No

93+00 No Yes Yes 134+00 No No No

94+00 Yes Yes Yes 135+00 No No No

95+00 Yes Yes Yes 136+00 No No No

96+00 Yes Yes Yes 137+00 No No No

97+00 Yes Yes Yes 138+00 No No No

98+00 Yes Yes Yes 139+00 No No No

99+00 No Yes Yes 140+00 No No No

100+00 No No No 141+00 Yes Yes Yes

101+00 No No No 142+00 Yes Yes Yes

102+00 No No No
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19.4 Soil Survey Report has just arrived:  
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28) The District Geologist indicated the Rock line would be below the “Weathered 

Dolomite” layer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



OpenRoads Designer Road 2 Rock Excavation 
 

18 Missouri Department of Transportation 12/23/25 

29) A summary of the Soil’s Report 

Depth of Cover (doc) to the Rock 

Line is listed in the following 

chart: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Station 72' Left C/L 72' Right

(feet) (feet) (feet)

62+00 17.31 7.26 8.31

63+00 15.45 9.88 8.44

64+00 15.59 12.51 8.57

65+00 18.17 10.41 7.95

66+00 20.74 8.31 7.32

67+00 9.46 6.21 3.98

68+00 7.87 4.11 2.99

69+00 6.28 2.01 No Core

70+00 4.39 3.65 No Core

71+00 2.5 5.29 No Core

72+00 3.52 3.49 No Core

73+00 3.01 2.645 No Core

Break in Borings Break in Borings Break in Borings Break in Borings

        Station ??+??.?? === Bridge Exception === Station ??+??.??

Break in Borings Break in Borings Break in Borings Break in Borings

87+00 9.29 8.11 7.26

88+00 7.42 7.62 8.44

89+00 5.55 7.13 9.62

90+00 6.54 4.63 4.24

91+00 4.27 4.26 3.95

92+00 No Core 3.88 3.65

93+00 No Core 2.95 4.26

94+00 7.66 2.01 4.86

95+00 8.21 9.52 9.69

96+00 7.11 7.87 6.9

97+00 6.01 6.21 4.11

98+00 6.56 4.41 6.05

99+00 No Core 7.8 7.32

Break in Borings Break in Borings Break in Borings Break in Borings

103+00 No Core 11.2 8.6

104+00 7.21 8.74 6.95

105+00 12.41 6.28 5.29

106+00 8.19 4.96 5.74

107+00 3.98 3.65 6.19

108+00 7.65 6.83 6.64

109+00 No Core 7.62 4.32

Break in Borings Break in Borings Break in Borings Break in Borings

117+00 6.6 7.08 No Core

118+00 4.63 5.75 No Core

119+00 4.77 5.44 7.01

120+00 4.9 5.13 6.6

121+00 2.01 5.16 5.19

122+00 No Core 3.58 5

123+00 No Core 0 4.8

Break in Borings Break in Borings Break in Borings Break in Borings

125+00 6.57 3.01 4.03

126+00 7.88 9.23 9.95

127+00 6.77 8.28 8.24

128+00 5.65 7.32 6.54

129+00 4.95 5.88 5.55

130+00 No Core 4.44 4.57

131+00 No Core 7.26 6.54

132+00 No Core 5.85 5.75

Break in Borings Break in Borings Break in Borings Break in Borings

141+00 9.56 6.6 7.26

142+00 11.92 7.18 6.88



OpenRoads Designer Road 2 Rock Excavation 
 

12/23/25 Missouri Department of Transportation 19 

19.5 Creating the Rock Surface from Borehole Data 

19.5.1 Plotting the Borehole Locations: 

In the next few pages, we are going to take the information from the soil report and plot 

the locations of the Boreholes.   

30) Create a new file named Borehole_Locations_J5U0441G.dgn  

a. Use the MoDOT_Roadway_Seed_2D.dgn seed file. 

b. Set the Geographic Coordinate System using the settings found in the 

Terrain_Existing_Ground_J5U044G.dgn  

c. Reference in the following dgn files: 

Civil_Geometry_J5U0441G.dgn 

    Terrain_Existing_Ground_J5U0441G.dgn 

d) Set Annotation Scale to 50 

e) Activate Existing Ground Terrain. 

 

31) Next, we need to plot the locations of the Rock Boreholes in the dgn file.  We will do this 

by processing a CSV file of the locations of the Rock Borings.  The CSV file will be in 

the formation of Point Name, Station, Offset.   

 

 
 

Note: We extended the Beginning and Ending Station by 0.30 ft of each section of 

Boreholes so that when we cut Cross Sections, we don’t place a section right on 
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the edge of a Surface/Mesh.   For example, Beginning Station 62+00 was entered 

in as 61+99.70 and Ending Station 73+00 was entered as 73+00.30 

 

Below is an example of a Cross Section cut right on the edge of a Rock Surface/Mesh 

Element. 

 

Note:  The Rock Mesh Element below was created by taking the Rock Surface that we 

will create shortly and adding a depth to that surface.  We will be doing all of this 

later in the exercise along with the Rock Benching you see in the Cross Section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you cut a section, just inside the Rock Mesh Element (0.01ft), you will see you will 

get the entire Mesh Element. 
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32) Select the Geometry Tab ➔  General Tools Section ➔ Import/Export ➔ Import 

Horizontal Points from Ascii File 

 

a) Select the Route 179 Alignment 

b) Select the Borehole Locations Station-Offset.csv 

 

Note: At this point the Import Horizontal Points from ASCII File dialog will open. 

 

c) Select the 3rd icon over from the Left ➔ Create New Text Import Settings File 

▪ Select the Columns Tab 

• In the Options section Select Delimited Separators 

• In the Column Delimiters section, Check Comma 

• In the bottom section, set the column heads as follows 

o Column1 ➔ Name 

o Column 2 ➔ Station 

o Column 3 ➔ Offset 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

d) Select Finish and save the Text Import Wizard Settings File as:  

 

   Borehole Locations Station-Offset_TIW.xml 

 

Note: TIW = Text Import Wizard 
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e) Set the Feature Definition to COGO Points, which can be found in the following 

location:  

Point ➔ Design ➔ Drafting Standards ➔ Miscellaneous ➔ COGO Point 

 

  
 

f) Select Import 
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Next, we are going to assign the Existing Ground Elevation to the COGO points place 

in the previous step. 

 

33) First place the COGO points into a Selection Set using the Element Selection Tool, and 

the Color Tab in the Extended Settings: 

 

  
 

 

34) Set the Elevation by using the Modify Points Tool by selecting the OpenRoads 

Modeling Workflow ➔ Geometry Tab ➔ Horizontal Section ➔ Point Tools 

 

 

 

 

 

 

 

 

 

 

 

 

 

Mode:   Named Terrain Model / Mesh 

Elevation Offset: 0.0000 

Rotation Mode: No Change 
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35) Once again put the COGO Points into a selection set using the Element Selection Tool.  

You should only get 130 points, if you get 260 points turn off the Default-3D view 

within the Reference Dialog. 

 

36) Verify the COGO Points have elevations by using the Point Feature Station Offset 

Elevation Report by selecting the OpenRoads Modeling Workflow ➔ Geometry Tab 

➔ General Tools Section ➔ Report Tools 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  The Horizontal Point Report will also show the elevations of the COGO points.  Also, 

with Reports you can Right-Click on the report and get some Export Options. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Creating the Rock Terrain: 
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In the next few pages, we are going add in additional the information from the Soil 

Report and create a Rock Surface.   

37) Create a new file named Terrain_Rock_Boreholes_J5U0441G.dgn  

a. Use the MoDOT_Roadway_Seed_3D.dgn seed file. 

b. Set the Geographic Coordinate System using the settings in the following file: 

Terrain_Existing_Ground_J5U0441G.dgn  

c. Reference in the following dgn files: 

Civil_Geometry_J5U0441G.dgn 

d. Set Annotation Scale to 50 

 

38) Next, we need to plot the Top of Rock locations of the Boreholes in the dgn file.  We 

will do this by processing a CSV file of the locations of the Rock Borings.  The CSV file 

will be in the format of Point Name, Station, Offset, Rock Elevation.   
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39) Select the Geometry Tab ➔  General Tools Section ➔ Import/Export ➔ Import 

Horizontal Points from Ascii File 

 

a) Select the Route 179 Alignment 

b) Select the Borehole Location Station-Offset-Elevation.csv 

 

Note: At this point the Import Horizontal Points from ASCII File dialog will open. 

 

c) Select the 3rd icon over from the Left ➔ Create New Text Import Settings File 

▪ Select the Column Tab 

• In the Options section Select Delimited Separators 

• In the Column Delimiters section Check Comma 

• In the bottom section set the column heads as follows 

o Column1 ➔ Name 

o Column 2 ➔ Station 

o Column 3 ➔ Offset 

o Column 4 ➔ Elevation 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

d) Select Finish and save the Text Import Wizard Settings File as:  

 

Borehole_Locations_with_Top-of-Rock_Elevations_J5U0441G_TIW.xml 

 

Note: TIW = Text Import Wizard 
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e) Set the Feature Definition to COGO Points, which can be found in the following 

location:  

Point ➔ Design ➔ Drafting Standards ➔ Miscellaneous 

 

 
 

f) Select Import 

 

40) In the View 1, Turn off the Display(s) of the Civil_Geometry_J5U0441G.dgn 

 

 

19.5.2 Creating the Rock Terrains 

 

41) Next, we are going to create Rock Terrain Models from the 3D COGO points placed in 

the previous step. 

 

One by one, place each group of COGO points into a Selection Set, using the Element 

Selection Tool, by placing a selection fence around each group of points. 
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42) Select the From Elements tool located within the Terrain Tab ➔  Create Section  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

43) After creating the first Rock Terrain, repeat steps until all six groups of Rock shots have 

been processed and their terrains created. 

 

Next, we are going to delete all the COGO Points.  The reason we are going to do this is 

to stop the COGO Points from automatically showing up in our Corridor and XS 

Models.  

 

44) Before we can delete the COGO Points, we need to first drop the rules in the  six (6) 

newly created Rock Terrains.  This has to be done individually one at a time. 

 

Note: If you don’t drop the rules first before 

deleting the COGO Points, the terrain 

in some instances will not hold it current 

shape. 

 

45) Detach all Reference Files. 

 

46) Next, place the COGO points into a Selection 

Set using the Element Selection Tool, and the 

Color Tab in the Extended Settings. 

 

47) Select Delete.   

 

 

 

 

 

 

 

 

 

 

Feature Type:  Spot 

Edge Method:  Max Triangle Length 

Max Side Length: 150ft  (XS Spacing x 1.5) 

Feature Definition: Existing Rock Surface 

Name:   Rock Boreholes-1 

Note: When adjusting the Name, be sure to Enter 

or Tab in the name field, otherwise the tool 

will apply the Default name. 
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48) Verify the naming of each Rock Surface either by hovering over each Terrain or using 

Explorer ➔ Open Roads Model ➔ Terrain Models ➔ Existing Rock Surface 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

49) In this step we are going to reopen the Corridors_Preliminary_J5U0441G.dgn file and 

reference in the Terrain_Rock_Boreholes_J5U0441G.dgn to see how the Rock Surface 

is laying out compared to the Corridor Template. 

 

Open the Corridors_Preliminary_J5U0441G.dgn 

 

Within the View 1, Default reference in Terrain_Rock_Boreholes_J5U0441G.dgn 

 

50) Open the Dynamic Cross Sections and review the Rock Layer at the Major 100’  

Stations locations. 
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19.5.3 Extending the Rock Terrain Surface: 

 

The rock terrain that we have created extends from Centerline of Route 179 out to the 

Back of Ditch location.  For the Rock Benching to draw in your cross sections we will 

need to extend the rock past the benching.  We can do this by utilizing the Extend 

Rock Template in the MoDOT section of the Template library. 

 

  

 

 

 

 

 

 

 

 

 

Note: The diagram below displays how the Extended Rock Template works. 

 

 

 

 

 

 

 

 

 

 

 

51) Open the Project Template Library J5U0441G.itl using the Create Template tool located 

within the OpenRoads Modeling Workflow ➔ Corridors Tab ➔ Create Section 

 

a) Copy the Extend Rock template from the Components ➔ Benching folder and 

place it in the J5U0441G folder. 

b) Review the Extend Rock template along with the documentation on the following 

two pages.   
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Note:  The Extend Rock template is described below (only Left Side Showing). 
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The Value Equation is located here in the Point Properties dialog box. 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Value Equation uses two points to calculate the value.  You have two options with 

Value Equation,  Horizontal or Vertical Difference. 

 

 

 

 

 

 

=|$(LT_Seek_Ground_1)-$(LT_Seek_Ground_2)*-1.000 

In the Extend Rock Template the Value equation helps us find the Vertical Elevation 

Difference of the two Seek Ground Points.  Once that is determined  the template 

applies that difference to the outside Rock point. 



OpenRoads Designer Road 2 Rock Excavation 
 

12/23/25 Missouri Department of Transportation 33 

52) Close Template Library. 

In the next few steps, we are going to place a shape around each Rock Surface.  The 

shapes will define the edge of the Rock Surfaces and will have a Feature Definition of 

Geometry Scratch.  The Extend Rock template will utilize this shape when extending 

the Rock Surface.  We will place these shapes in the plan file. 

53) Create a new file named Plan_J5U0441G.dgn 

a. Use the MoDOT_Roadway_Seed_2D.dgn seed file. 

b. Set the Geographic Coordinate System using the settings in the following file: 

Terrain_Existing_Ground_J5U0441G.dgn  

c. Reference in the following dgn files: 

Terrain_Rock_Boreholes_J5U441G.dgn 

54) Merge into Master the Terrain_Rock_Boreholes_J5U441G.dgn file. 

55) Next, we are going to create the Shapes around each Rock Surface.  To do this use the 

Create Region Tool located within: OpenRoads Modeling Workflow ➔ Drawing Tab 

➔ Groups Section 

 

Use the following settings below:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  When creating the shape, it might look like the Create Region tool is not 

enclosing the entire shape, but what is really happening is the Terrain Element, in 

certain areas, is visualizing on top of the shape element. 
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56) Using the Element Section tool select and delete all items that have an Element Color 

of 78. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

57) Set the Feature Definition of the shapes to Geometry Scratch using the Set Feature 

Definition Tool located within the OpenRoads Modeling Workflow ➔ Geometry Tab 

➔ General Tools Section ➔ Standards Tools. 

 

58) Create a new file named Corridors_Extend_Rock_J5U0441G.dgn 

a. Use the MoDOT_Roadway_Seed_2D.dgn seed file. 

b. Set the Geographic Coordinate System using the settings in the following file: 

Terrain_Existing_Ground_J5U0441G.dgn  

c. Reference in the following dgn files: 

Civil_Geometry_J5U0441G.dgn 

Plan_J5U441G.dgn 

Terrain _Existing_Ground_J5U0441G.dgn 

Terrain_Rock_Boreholes_J5U441G.dgn 

d. Set Annotation Scale to 50 

e. Activate Existing Ground Terrain. 
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59) Select the “Corridor Tab ➔ Create Section ➔ New Corridor” tool. 

a) Select the Route 179 baseline (use the active profile) and name the corridor 

Rte179. 

b) Apply the following Roadway template: 

 J5U0441G ➔ Extend Rock 

c) Create other Template Drops using the stationing ranges listed below:  

 

▪ Sta. 61+99.80 to Sta. 73+00.20 

▪ Sta. 86+99.80 to Sta. 99+00.20 

▪ Sta. 102+99.80 to Sta. 109+00.20 

▪ Sta. 116+99.80 to Sta. 123+00.20 

▪ Sta. 124+99.80 to Sta. 132+00.20 

▪ Sta. 140+99.80 to Sta. 142+00.20 

 

d) Drop Interval of 20ft. 

 

Note:  Once again, we are offsetting 

the Start and Stop location of 

the Extend Rock Templates 

Drops so that  when we 

create a Terrain Surface of 

the extended rock corridor the 

Terrain Surface will extend 

slightly past the start and stop 

locations of the Final 

Roadway “Benching” 

Template Drops.  
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60) Select the “F6” key to open 3D view of model. 

 

61) Add as a Corridor Reference the Six Geometry Scratch shapes that represent the Rock 

Limits.  To help with this in the View 1, Default  you can turn off the Display of the 

Terrain_Rock_Boreholes_J5U0441G.dgn file 

 

62) You should notice many gaps in-between the Rock Surface and the Extended Rock 

Surface. 
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The Extend Rock template has two points Seeking one of the Six (6) Rock Terrain 

Surfaces.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The two points on the inside of the Rock_Extention_Line Component (see both Point 

#4s above)  have a Project to Surface Constraint that looks for the Rock Surface defined 

in the Value field. 

 

 

63) For each of the Six (6) Template Drops, set the appropriate Rock Boreholes-X Surface 

for the LT_Extend_Rock_1 and RT_Extend_Rock_1 points. 

 

Note:  If there are spikes in your 3D Rock Extension Model, verify you are using 0-Preliminary 

x5 Corridor Feature Definition.  With this Corridor Feature Definitions, the Densify 

Vertical setting is set to False.   When this setting is set to True, spikes tend to draw in 

the model. 

 

64) Once the Rock Extension is done for all sections, review how the Rock Extension is 

drawing within the Cross Section or 3D View. 

 

65) Open the Corridors_Preliminary_J5U0441G.dgn 

 

66) Within View 1, Default reference in the Corridors_Extend_Rock_J5U0441G.dgn 

 

67) Open the Dynamic Cross Sections and review the Extended Rock Layer. 
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68) After reviewing the Dynamic Cross Sections Detach the following two files from the 

View 1, Default window and if necessary, the View 2, Default-3D window: 

    Corridors_Extend_Rock_J5U0441G.dgn    

   Terrain_Rock_Boreholes_J5U0441G.dgn 

 

19.5.4 Creating a Terrain for the Extend Rock: 

69) Create a new file named Terrain_Extend_Rock_J5U0441G.dgn 

a. Use the MoDOT_Roadway_Seed_3D.dgn seed file. 

b. Set the Geographic Coordinate System using the settings in the following file: 

Terrain_Existing_Ground_J5U0441G.dgn  

c. Reference in the Default-3D Model of the following dgn file: 

Corridors_Extend_Rock_J5U441G.dgn 

 

70) Within the Level Display and the Corridors_Extend_Rock_J5U0441G.dgn, Turn Off 

the Default and Scratch-1 levels. 
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71) Within the Reference Dialog, select the Default-3D Model and then select Tools ➔ 

Merge into Master. 

 

Then Left Click in a blank area to accept the Merge. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

72) Select all Extended Rock Corridor Features and then select Drop Element Tool located 

withing the OpenRoads Modeling Workflow ➔ Drawing Tab ➔ Groups Section ➔ 

Drop Tools. 

 

Toggle on Solids and set To Wireframe 

 

Note: Droping Solids - (3D only) If checked 

ON, the associated option menu lets you 

drop SmartSurfaces or SmartSolids: 

 

To Geometry - They are dropped to 

simple surfaces. 

To Wireframe - They are dropped to 

wireframe elements. 
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73) Create a terrain model for each Extended Rock Template Geometry using the From 

Elements tool located within the OpenRoads Modeling Workflow ➔ Terrain Tab ➔ 

Create Section.   

 

Increment the Terrain Feature Name accordingly for each Rock Surface, making sure 

you select the Enter or Tab key to lock in the Name, else the name won’t stick. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Notes: We are using a Feature Definition of Design Triangle so that the Symbology is 

different when we Complex the Extended Rock Terrain and the Terrain created from 

the Boreholes. 

 

Once again when adjusting the Name, be sure to Enter or Tab in the name field, 

otherwise the tool will apply the Default name.  

 

74) Clean Up any bogus triangles as needed, using the Terrain Edit Model tools located 

within the OpenRoads Modeling Workflow ➔ Terrain Tab ➔ Edit Section. 

 

Note: To help with determining which Triangles need to be deleted, you can turn On and Off the 

Modeling-Terrain-Proposed Level. 

 

75) Turn off the Extended Rock Graphics by using the Level Display Tool and turning off 

the XS-Existing subsurface-rock Level. 

 

 

19.5.5 Creating the Rock Final Terrain: 

76) Create a new file named Terrain_Rock_Final_J5U0441G.dgn 

d. Use the MoDOT_Roadway_Seed_3D.dgn seed file. 

e. Set the Geographic Coordinate System using the settings in the following file: 

Terrain_Existing_Ground_J5U0441G.dgn  

f. Reference in the following dgn file: 

Terrain_Extend_Rock_J5U0441G.dgn  

Terrain_Rock_Boreholes_J5U441G.dgn 
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77) Create a terrain model for each rock area using the Create Complex Terrain Model tool 

by selecting the OpenRoads Modeling Workflow ➔ Terrain Tab ➔ Create Section ➔ 

Additional Method Tools. 

 

Increment the Terrain Feature Name accordingly for each Rock Surface. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: We are using a Feature Definition of Existing Triangles so that the Symbology is 

different than the two Symbologies of the Terrains we are Merging.  By doing so, we 

will be able to see how well the Surfaces Merged together.  We will adjust this Terrain 

Feature Definition at a later step. 

  

 To help with visualizing how the Terrains Merged together, you can turn On and Off the 

Modeling-Triangle-Existing Level. 

 

 If the Rock Terrain Model is created but is not visible, go into Explorer, Delete the 

Terrain Model, run the ORD Clean-up Tool and reapply the Merge. 

 

After typing in the Terrain Name for the first time, highlight and copy the Final Rock-1 

name so that it can be pasted into the dialog box for Final Rock-2 through Final Rock-6 

names.  The tool does not remember the previous terrain named used. 
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78) Within each newly created Rock Final Terrains, remove the rules back to the original 

terrains. 

 

 

 

 

 

 

 

The easiest way to Remove the Rules using the Explorer ➔ OpenRoads Model 

Section. 

 

 
 

79) Once all the Rules have be Removed withing the Reference 

dialog select Tools ➔ Detach All 

 

80) Within all the Final Rock Terrain Models, set the Feature Definitions to Existing Rock 

Boundary.   

 

Note: Unlike dropping the terrain Rules, you can use Explorer to bulk edit the Terrain 

Feature definition. 
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The next few steps we are going to recreate our Corridor and then Cross Sections so that 

we can calculate our Rock Excavation using the End Area Method and Cross Sections 

every 100 feet.   Within our Corridor we need to add to our roadway template a Benching 

Component, so that Rock Benching will draw if our Roadway template crosses our Rock 

Surface.  The Benching Template should follow the guidelines specified in the Soil 

Survey as for as Bench Height, Bench Width, Ditch Width, and the Soil Back Slope. 
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19.6 Creating the Benching Template: 

81) Open the Cole\J5U0441G\Corridors_Preliminary_J5U0441G.dgn. 

 

82) Select Save As and name the new file as Corridors_Rock_J5U0441G.dgn.  

 

83) In View 1, Default, reference in the Terrain_Rock_Final_J5U0441G.dgn located in the 

Final sub folder. 

 

84) Verify the active Template Library is pointing to the J5U0441G.itl 

 

85) In the dgn Edit the Template Drop. 

 

We are going to add the Rock Benching  on the Left side of the Template first and then 

come back and do the Right side. 

 

86) Modify the Priority of  the End Conditions on both sides of the Route 179 Template 

Drop with the following: 

▪ Ditch End Condition = 3 

▪ Fill End Condition = 4 

 

87) Verify Apply Affixes are turned on and Step Options are greater than zero. 

 

88) Add to the Left outside Shoulder Point (LT_O_AsphSurf_T_O_EOS) a Benching 

Components called Rock Benching located within Components ➔ Benching 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  Verify when placing the Benching Component that only the Origin Point Merges with 

the existing Shoulder Point.  In some cases, if the new Template geometry is similar to 

the existing Template Geometry, sometimes the Common Points will all merge together. 

If needed place the template in a blank area and move the elements. 
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89) Within BOTH Benching Component Properties verify the Target Type is set to 

Terrain Model and the Terrain Model is set to Rock Final 1. 

 

90) Select the Test button to verify the Benching Component is seeking the Rock Surface. 

 

91) Verify the Rock Ditch is unable to draw when the Rock Surface is sloping down to the 

Right.  

 

92)  Once again add to the Left outside Shoulder Point (LT_O_AsphSurf_T_O_EOS) a 

second Benching Components called Rock Surface Below Benching Wall w/Ground 

Backslope located within Components ➔ Benching 

 

Note:  Verify when placing the Benching Component that only the Origin Point Merges with 

the existing Shoulder Point.  Again, in some cases, if the new Template geometry is 

similar to the existing Template Geometry, sometimes the Common Points will all merge 

together. 

 

93) Verify using the Test button that the Rock Ditch is now able to draw when the Rock 

Surface is sloping down to the Left within the Ditch area.  (Hint, with the Rock Surface use 

a positive slope like 5% or 10%) 
 

94) Close and Save the Template Library.               

 

95) Selecting the Corridor Grips, Open the Dynamic Cross Section Model.                  

Verify the Rock Bench is drawing in area of the first Rock Surface/Terrain. 
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Next, we’re going to focus on what happens after the Benching component draws up to the 

Rock Surface.  In this example we are going to first follow the Top of Rock Surface out 

until it finds the Slope of Repose.  Once it finds the Slope of Repose, we will then seek 

the Existing Ground Surface with a 4:1 End Condition. 

In the next step we will add a temporary component to help us visualize where the Slope of 

Repose is located. 

 

 

 

 

 

 

 

 

96) Select the Berm Component located under Components ➔ Berm and place it in a 

blank area of the template near the LT_Back of Ditch location. 

 

97) Edit the Berm Component by modifying the following: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Feature Definition ➔ Mesh\Design\Design Standards\Modeling\Corridor Meshes\Bottom Mesh 
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Notes:   We are changing the Feature Definition to help make Slope of Repose line stand 

out from the other elements (Orange Line). 

  

 By defining the Parent Component, the Berm Component (Slope of Repose) will 

only draw if the Rock Benching Draws.   

 

98) Modify the LT_Berm_B point with the following Constraint Settings: 

 

99) Move the LT_Berm_T Point to the LT_Back of Ditch point. 

100) Left-Click on the LT_Berm_T Point and select Merge. 

When asked Delete Point, select the LT_Berm_T point.  Then when asked Merge 

LT_Berm_T With Point, select the LT_Back of Ditch (Rock) point. 

 

 

  

 

Note:  We placed the Berm (Slope of Repose) this way so that we could control which 

point the LT_Berm_T Point would be merged with.  We wanted the LT_Berm_T 

Point to merge with the point that is part of the Bench Wall. 
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Next step we will add a Component to the Rock Wall that will follow the Slope of the Rock 

until it intersects the Slope of Repose. 

 

 

 

 

 

 

 

 

 

Important Notes about adding to Benching Components and End Conditions: 

• Benching Component is an End Condition with the Benching Count option 

Turned On. 

• If an End Conditions is added to the last point of a Benching Component, the 

End Condition will typically always draw on the last segment of the Benching 

Component. 

• If a regular Component (Non-End Condition) is added to the last point of a 

Benching Component, the Component may or may not always draw on the last 

segment of the Benching Component.  If you need to add a regular Component 

(Non-End Condition) and it needs to be draw on the last segment of the Benching 

Component, add an End Condition to the end of the Benching Component. 

• After adding End Condition to a Benching Component, if the End Condition is 

checking for interception and does not hit its Target the End Condition and the 

Benching Component will not Display. 

• You can have many End Conditions branching off of a single point, but the only 

End Condition that will Display is the one that finds its Target and has the 

Lowest Priority.  If all the branching End Conditions have the same Priority and 

they all find their Target, typically the first End Condition added will be the 

only one that Displays.  

101) Select the Berm component located under Components ➔ Berm and place it on the 

LT_Bench_Outer point. 

You will notice (as described above about adding to a Benching component) that the 

Berm is not drawing on the last segment of the Benching Component. 
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102) To fix this issue in the last step, select the Ditch Back Slope 1 (4:1) End Condition 

located under End Conditions ➔ Ditch and also place it on the LT_Bench_Outer 

point. 

103) Adjust the LT_Ditch_Bkslp_1_T2 point with the following settings to temporarily turn 

off the End Condition.  We will come back to this End Condition at a later step. 

 

104) Double-Click on the newly placed Berm Component and change the following settings 

listed below:  

 

Feature Definition ➔ Mesh\Template Components\Grading\XS_Ground_Proposed 
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105) To get the Berm Component in the proper orientation, Modify the LT_ Berm_B point 

with the following Settings, modifying Constraint 2 first then Constraint 1: 

 

106) To get the LT_Top Bench (Sloped) to follow the Rock Surface out to the Slope of 

Repose modify again the LT_Seek Slope of Repose 1 point with the following Settings: 

 

Note:  We purposely used a “Regular” Component over an End Condition, because based on 

the testing we did, the “Regular” Component (Berm) seemed to trace the ground more 

accurately with the point settings listed above...  
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Next, we need to add another End Condition to left side of the LT_Top Bench Sloped 

Component that will draw to the Existing Ground Terrain model. 

107) Again, select the Ditch Back Slope 1 (4:1) End Condition located under End Conditions 

➔ Ditch and place it on the LT_Seek Slope of Repose 1 point. 

108) Modify the Ditch Back Slope 1 (4:1) Component with the following settings: 

 

109) Modify the LT_Dtch_Bkslp_1_T3 Point with the following settings: 

  

Constraint 1 Parent 2 ➔ LT_Seek Slope of Repose 1 
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Note: One thing we have to think about is when the template traces the Rock Surface will it 

“Catch Water”?  If so, this is typically an undesirable result, in this situation a flat slope 

would be more desirable.  So in the next several step we will incorporate a Display Rule 

to draw a Flat Top Slope when we encounter the Rock Surface sloping away from the 

Rock Bench. 

 

 

 

 

 

 

 

 

 

 

 

110) Edit the LT_Dtch_Bkslp_1_T2 point and toggle OFF Do Not Construct. 

111) Double click on the LT_Ditch Back Slope 11 End Condition and modify the following 

settings: 
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112) To get the End Condition in the proper orientation, Modify the LT_Dtch_Bkslp_1_T* 

point with the following Settings: 

  

 

Notes: 

• If Use Feature Name Override was left on the point would draw to the 

other LT_LOC_Cut point in the previously placed End Condition.  Later we 

will turn this option “ON” after we apply a Display Rule for our two Top of 

Bench solutions (Flat vs. Sloped). 

• The reason we are turn OFF Check for Interception, is to get the End 

Condition to temporally draw while we construct the remainder of the 

template. 
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113) To get the LT_Top Bench (Flat) to draw out to the Slope of Repose modify again the 

LT_Seek Slope of Repose 2 point with the following Settings: 

 

 

Next, we need to add another End Condition to the left side of the LT_Top Bench (Flat) 

Component that will draw to the Existing Ground Terrain model. 

114) Again, select the Ditch Back Slope 1 (4:1) End Condition located under End Conditions 

➔ Ditch and place it on the LT_Seek Slope of Repose 2 point. 

115) Modify the LT_Ditch Back Slope 11 Component with the following settings: 
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116) Modify the LT_Dtch_Bkslp_1_T2 Point with the following settings: 
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19.6.1 Interesting Notes about End Conditions, Benching, Parent/Child 

Relationships: 

Say you have Two End Conditions called “A” and “B”.  End Condition B is connected to 

its parent End Condition A.  End Condition A is connected to its parent the Rock Benching 

Component.  All elements are Checking for Interception. 

a) If the End Conditions and Rock Benching all find their targets, the End Conditions and 

the Rock Benching will all draw. 

b) If any of the End Conditions or Rock Benching can’t find their target, the End 

Conditions and Rock Benching will all not draw. 

 

 

Notes: A Child Component will only be displayed if it’s Parent Component is displayed. 

 When deleting Components/End Conditions, deleting a Parent deletes all Children too. 
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19.6.2 Template Display Rules 

We are going to use a Display Rule to draw the Flat Slope when the Rock Bench falls down 

and away Rock Bench Wall and follow the slope when it slopes upward. 

117) In the Dynamic Cross Section View navigate to Sta. 62+00 

In the next few steps, we are going to setup a Display Rule that will turn OFF the 

Display the LT_TOP Bench (Sloped) component when Rock Surface is sloping 

downward and away from the LT_Bench_Outer point.  

118) Edit the LT_Top Bench (Sloped) Component and select the Edit button right of Display 

Rules. 

 

  In the Component Display Condition Expression Dialog select the Add button. 

119) Set up the Display Rule dialog as follows: 
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120) Select the newly created Display Rule and Add it to the Condition Expression section 

of the dialog. 

 

Note:  The True/False result that is reported after selecting the equal (=) sign is based off 

the Current Template Location. 

121) You can now see the Display Rule within the Component Properties.  Select Appy and 

Close to the Component properties Dialog Box. 
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In the next few steps, we are going to setup a Display Rule that will turn OFF the 

Display the LT_TOP Bench (Flat) component when Rock Surface is sloping upward 

and away from the LT_Bench_Outer point.  

122) In the Dynamic Cross Section View navigate to Sta. 71+00 

123) Edit the LT_Top Bench (Flat) Component and select the Edit button right of Display 

Rules. 
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124) In the Component Display Condition Expression Dialog select the NOT button.  

Lastly select the previously defined Template Display Rule and Add it to the Condition 

Expression section of the dialog. 

Note:  The True/False result that is reported after selecting the equal (=) sign is based off 

the Current Template Location. 

125) You can now see the Display Rule within the Component Properties.  Select Appy and 

Close to the Component propeties Dialog Box. 
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126) You will notice when using a Display Rule with a Condition Expression that is False 

the Component will not display in the Template Window unless you select the Active 

Template Tab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

127) In the Dynamic Cross Section View navigate through the sections withing the first Rock 

Surface. 

128) Remove the temporary Slope of Repose line from the Template. 

 

129) In the Dynamic Cross Section View navigate to Sta. 74+00 
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130) You will notice that the Berm Component continues to draw even though there is no 

rock bench.  To take care of this we will define the Benching Component as the Top 

Bench (Sloped) Parent Component.  That way if the Benching Component does not 

draw, the Top Bench (Sloped) will not draw as well.  When Defining Benching 

Components as Parents, it recommended to select a Benching Component that does 

not have Benching Count (See Note below). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

131) Within the Berm Component, Set the Parent Component as the  LT_Foreslope and 

Ditch (Rock) Component. 

 

 
 

Note #1: The reason we did not use the Rock Wall as the Parent Component is because in 

doing so the Lt_Top Bench (Sloped) Component (Berm) would start to draw on several 

segments of the Rock Wall. 
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Note #2:  The reason we did not use two End Condition for the Flat and Sloped Components 

is because Display Rules have no effect on the End Condition Priorities.   

 

Example 1:  Display Rules and End Conditions 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Scenario 1)  There is a Display Rule that toggles between Displaying the Sloped End 

Condition and the Flat End Condition, and at a certain Template drop the 

Display Rule tries to Visualize the Sloped End Condition    

   Result = Sloped End Condition WILL Display.  

Scenario 2)  There is a Display Rule that toggles between Displaying the Sloped End 

Condition and the Flat End Condition, and at a certain Template drop the 

Display Rule tries to Visualize the Flat End Condition    

  Result = Flat End Condition will NOT Display.  

 This is because the Flat End Conditions has a lower Priority (2) than the Sloped 

End Condition (1)  and will not draw even though the Display Rule is turning it 

ON. 

 Remember a higher End Condition Priority is the one with a lower number. 

 

 

 

 



OpenRoads Designer Road 2 Rock Excavation 
 

64 Missouri Department of Transportation 12/23/25 

Example 2:  Display Rules and End Conditions 

 

 

Scenario 3)  There is a Display Rule that toggles between Displaying the Sloped End 

Condition and the Flat End Condition, and at a certain Template drop the 

Display Rule tries to Visualize the Sloped End Condition    

    Result = Sloped End Condition will NOT Display.  

Scenario 4)  There is a Display Rule that toggles between Displaying the Sloped End 

Condition and the Flat End Condition, and at a certain Template drop the 

Display Rule tries to Visualize the Flat End Condition    

   Result = Flat End Condition WILL Display.  

 This is because the Sloped End Conditions has a lower Priority (2) than the Flat 

End Condition (1)  and will not draw even though the Display Rule is turning it 

ON. 

Remember a higher End Condition Priority is the one with a lower number. 

 

Conclusion:  Display Rules do not have a higher level of control over End Condition 

Priorities.  End Condition Priorities will always supersede Display Rules.  In 

other words, even though a Display Rule is allowing an End Condition to 

display, the End Condition Priority may still not allow it to draw. 
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Example 3:  End Conditions with Same Priority 

 

 

Scenario 5)  There is no Display Rules to toggle between Displaying the Sloped End 

Condition and the Flat End Condition, and both End Condition can solve for 

their target.    

    Result = Sloped End Condition WILL Only Display  

 This is because the Sloped End Condition (Priority = 1) was added to the 

template first, and then the Flat End Condition  (Priority = 1) was second. 

If the End Condition priorities are equal, the first End Condition placed in the 

template will be the only End Condition to draw.  

 

 

Conclusion #2:  The relationship between Display Rules and End Condition Priorities is the 

reason we did not use two End Condition to solve for the two “Tie to 

Ground” scenarios/components we have set up.  By using a “Regular” 

Component for either the Slope or Flat Element that branches off the 

LT_Bench_Outer point we are able to then utilize a Display Rule to turn the 

elements OFF and ON. 
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19.6.3 Point - Feature Name Override 

Next, we will edit the Roadway Template by turning ON the Use Feature Name 

Override option on several of the Template Points.  

 

Notes: Use Feature Name Override displays the Override Point Name of the feature 

that will be created in the surface to correspond to the point.  This field is 

optional.  If it is blank, then the Original Point Name will be used as the 

Feature Name.   

 

Another way of describing Point Property Feature Name Overrides, is that it 

changes the final design surface Point Names (which can be many) to a 

Common Single Name for different tie slopes. 

 

• The option is intended primarily for End Condition components to create 

connectivity from one template drop to the next, when the template End 

Conditions change.  

 

• For example, if you want all surface tie-in points to belong to one feature, then 

set the feature name of all the ending end condition points on each side of the 

template to the same name (i.e. all Cut and Fill End Points on the Right would 

be given the feature name R-Tie and all the ones on the Left would be given the 

feature name L-Tie). 

 

• If the Point has a Feature Name Override defined, the point name is displayed in 

Red in the Template window. 

 

• Also helps Avoids End Condition Transition Issues. 

 

132) Use the following two Named Overrides listed in the diagram below for the four Points 

indicated. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



OpenRoads Designer Road 2 Rock Excavation 
 

12/23/25 Missouri Department of Transportation 67 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Without Point Name Overrides 

With Point Name Overrides 
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19.6.4 Component - Feature Name Override 

Next, we will edit the Roadway Template by turning ON the Use Feature Name 

Override option on several of the Template Components.  

 

Notes: Use this dialog to set the Component Name Override property on a group of 

components. Be careful when using this dialog to ensure that only components 

that are mutually exclusive to the solution at any given station will be assigned to 

the same component name.  

 

Component Name Override does not apply to component display rules, Active 

Template list, or Parent/Child pulldown. 

 

The first encountered component's feature definition is used for all components 

with that override. 

 

Component Feature Name Overrides help with gaps in models where Display  

Rules in abutting template drops display different components.   

 

 

133) Use the following two Named Overrides listed in the diagram below for the four 

Components indicated. 
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Without Component Name Overrides 

With Component Name Overrides 
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Next, we need to add the Rock Benching component on the Right side of our Roadway 

Template. 

 

134) But, before we add the Rock Benching Components adjust the Priorities of the right 

Ditch (to Priority 3) and right Fill (to Priority 4) End Conditions  

 

135) Select the Rock Benching with Top of Bench Ground Sloped/Flat Component located 

under Components ➔ Benching and place it on the RTO_AsphSurf_T_O_EOS Point. 

 

Make sure you have Apply Affixes Turn on. 

 

136) Using the diagram below make sure the Components and Points are targeting the Final 

Rock-1 Surface. 

 

137) Once the Template is fully created it might be beneficial to save it in the Project itl.  

Using the Template Library Organizer, copy the Active Template into the J5U0441G 

Folder and call it 4 Lane Asphalt w/ Type C Barrier with Rock Benching. 

 

Note: One thing you probably notice is that this Template is only good for the First Rock 

Surface because the Left and Right Rock Benching Components are seeking the 

Terrain Model called Rock Final 1. 

 

 Also, the Point Seek Slope of Repose on each side of the Template is also Projecting to a 

Rock Final 1 Surface (Terrain) 
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To make the Template draw to the other Rock Surfaces we will need to adjust Template Drop 

Stationing for the first Rock Surface, and then copy multiple times the template drop so 

that each Rock Surface has their own Template drop. 

 

138) First, adjust the Station Range of the Template Drop by selecting the Template Grips 

and adjusting the Start and Ending Station to Sta. 61+99.90 and Sta. 85+00.10. 

 

139) Selecting the “heads-up” tools on Template Drop select 

Copy Template Drop, apply to the RTE179 Corridor and 

using a Station Range of Sta. 85+99.90 to Sta. 101+00.10. 

 

IMPORTANT:  Make sure after the Template Drop has been added that there is only 

one Corridor. 

 

140) In the Second Template Drop adjust The Rock Surface that the Template Elements 

(discussed on the previous page) are Targeting that  need to point to Rock Final 2 

Surface (Terrain). 

 

You will need to modify the following Components and Points on both sides of the 

Template: 

      Components     Points 
  

Bench_Wall (Rock)    Seek Slope of Repose 

 Foreslope and Ditch (Rock) 

 Foreslope and Ditch (Rock) B 

 

141) Open the following file located under data\Final\Corridors_X_J5U0441G.dgn 

 

This file already has the following Template Drops ranges added: 

 

 Actual Station Ranges            Equivalent Station Ranges 

 

▪ Sta. 61+99.90 to Sta. 85+00.10  Sta. 62+00 to Sta. 85+00 

▪ Sta. 85+99.90 to Sta. 101+00.10  Sta. 86+00 to Sta. 101+00 

▪ Sta. 101+99.90 to Sta. 115+00.10  Sta. 102+00 to Sta. 115+00 

▪ Sta. 115+99.90 to Sta. 123+00.10  Sta. 116+00 to Sta. 123+00 

▪ Sta. 123+99.90 to Sta. 139+00.10  Sta. 124+00 to Sta. 139+00 

▪ Sta. 139+99.90 to Sta. 142+00.10  Sta. 140+00 to Sta. 142+00 

 

We will be creating Cross Sections and their corresponding Named Boundaries every 

100 ft down the Rte179 alignment.  Eventually we will also be creating Earthwork 

Meshes from this Corridor file.   Based on experience, we have determined it’s best 

not to start and stop the Template Drop ranges where XS Named Boundaries will 

be located, therefore we will use the “Actual” Station Ranges listed above.  

 

Also refer to Page 20 in this chapter about cutting sections right on the edge of a Mesh 

element.  
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19.7 Verify Cross Sections are drawing at Critical Locations 

142) Next, we need to review all the Cross Section in which we are planning use to calculate 

Earthwork.   In this exercise, our Earthwork End Area calculation will happen on even 

100-foot sections. 

The following are some examples of Cross Sections not drawing 100% correct, and how to fix 

each of their issues. 

Station 87+00, to fix this issue add a Key Station at 86+99.90 

 

Station 103+00, to fix this issue add a Key Station at 102+99.90 

 

Station 117+00, to fix this issue add a Key Station at 116+99.90 

 

Station 132+00, to fix this issue add a Key Station at 132+00.10 

 



OpenRoads Designer Road 2 Rock Excavation 
 

12/23/25 Missouri Department of Transportation 73 

19.8 Creating Rock Meshes to be used in Earthwork Calculations 

Up to this point we have created Rock Surfaces to be used/targeted by our Benching Template to 

help us define the limits of our Rock Excavation within our Cross Sections. 

Now we need to create a Rock Mesh to help OpenRoads Designer calculate the Rock 

Excavation using the Cut and Fill Volumes tool.  

 

139) Open the Create Closed Mesh tool located under the OpenRoads Modeling Workflow 

➔ Modeling Detailing Tab ➔ 3D Tools Section. 

Within the View 2, Default 3D use the following settings when applying the tool to the Final 

Rock-1 Surface. 

  

 

 

 

 

The Feature Definition is located here:  

  Mesh ➔ Existing ➔ Rock 

 

140) Using Create Closed Mesh tool apply the same settings to the remaining Rock Surfaces 

incrementing the Name (Rock Mesh-2, Rock Mesh-3, etc.).  

 

 

 

 

 

 

 

 

 

 

Use Fence:  Unchecked 

Method:  Element to Depth 

Depth:   75 

Feature Definition: Rock 

Name:   Rock Mesh-1 
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19.9 Create Cut and Fill Volumes: 

In the next few steps, we are going to setup and run the Cut and Fill Volumes tool.  Based on 

experience, we have discovered the more complex the Corridor Templates are, the more 

unsteady this tool becomes.  Also, the length of the corridor can have an impact on the 

stability of this tool. 

141) Open the Create Cut Fill Volumes tool located under the OpenRoads Modeling 

Workflow ➔ Home Tab ➔ Model Analysis and Reporting Section ➔ Civil Analysis 

Tools. 

142) Check on Compute Substrata and Accept all the prompts. 

 

 

 

 

 

 

143) You will notice that the program will melt down with this dataset. 

 

 

 

 

 

 

 

 

 

 

 

 

At this point the Designer will need to break up the Corridor into smaller sections to-the-point 

where the Create Cut Fill Volumes tool will function.  In this exercise we will break up 

our Corridor based on our six Existing Template drops. 
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144) Open the following file located under data\Final\Corridors_1-of-6_J5U0441G.dgn 

145) Open the Create Cut Fill Volumes tool located under the OpenRoads Modeling 

Workflow ➔ Home Tab ➔ Model Analysis and Reporting Section ➔ Civil Analysis 

Tools. 

146) Check on Compute Substrata and Accept all the prompts. 

 

 

 

 

 

 

 

147) When the Create Cut Fill Volumes tool works, it will draw Earthwork Meshes in View 

2, Default 3D.  The user will be able to view the meshes in the plan and XS view. 
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148) Next, we need to review the Cross Section view so that all meshes are drawn correctly on 

sections we’re planning use to calculate Earthwork.  In this exercise, our Earthwork End 

Area calculation will happen on even 100-foot sections. 

The reason we need to check these sections is because the Create Cut Fill Volumes tool does 

not always draw the Meshes fully on each section. 

 To demonstrate this issue, navigate to Station 65+00, at this section there are a couple of areas 

of concerns: 

 

 

 

   

 

 

Most of the times these gaps in the Mesh happen when the template is transitions from one 

template Drop to another, for example the following:  

Station Situation 

65+00 Two Rock Benches on the Left side 

65+20 One Rock Bench on the Left Side 

 

149) To fix the Mesh, insert a Key Station just 

after the 65+00 Template Drop, use a value 

of 65+00.10   

 

150) Meshes are not dynamic so after adding the Key Station you will have to 

delete Earthwork Volumes (on Levels Volumes-Rock Excavated, 

Volumes-Fill, and Volumes-Cut) that were created and rerun the Create 

Cut Fill Volumes tool.  It helpful to utilize the “Used” Filter in the Level Display. 

The Create Cut Fill Volumes tool is located under the OpenRoads Modeling Workflow ➔ 

Home Tab ➔ Model Analysis and Reporting Section ➔ Civil Analysis Tools. 
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151) Continue checking the Meshes at the full 100’even stations, adding Key Station where 

needed to help the Mesh to draw fully at those stations. 

Below is a list where we recommend Key Stations be added: 

 

The remaining dgn files have been processed for Earthwork and Key Stations added where 

necessary. 

Corridors_2-of-6_J5U0441G.dgn 

 

86+99.90, 89+00.10, 90+00.10, 90+99.90, and 91.00.10 

 

Corridors_3-of-6_J5U0441G.dgn 

 

102+99.90, 103+99.90, and 108+00.10 

 

Corridors_4-of-6_J5U0441G.dgn 

 

116+99.99, 118+00.10, and 119+00.10 

 

Corridors_5-of-6_J5U0441G.dgn 

 

126+99.90, 127+00.10, 128+99.90, and 132+00.10 

 

Corridors_6-of-6_J5U0441G.dgn 

No Key Stations 
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19.10 Create Cross Sections Sheets with Earthwork Quantities: 

152) Create a new file named:  

 Named_Boundary_Route-179_XS_Earthwork_J5U0441G.dgn  

a) Use the MoDOT_Roadway_Seed_2D.dgn seed file. 

b) Set the Geographic Coordinate System using the settings in the following file: 

   Terrain_Existing_Ground_J5U0441G.dgn 

 

c) Reference in the following dgn files from the J5U0441G/data/Final folder: 

    Civil_Geometry_J5U0441G.dgn 

   Corridors_1-of-6_J5U0441G.dgn 

Corridors_2-of-6_J5U0441G.dgn 

Corridors_3-of-6_J5U0441G.dgn 

Corridors_4-of-6_J5U0441G.dgn 

Corridors_5-of-6_J5U0441G.dgn 

Corridors_6-of-6_J5U0441G.dgn 

   Terrain_Existing_Ground_J5U0441G.dgn    

   Terrain_Rock_Final_J5U0441G 

 

d) Set Annotation Scale to 50 

e) Activate Existing Ground Terrain. 

f) Select F6 to open the Muli-Model View 
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19.11 Creating the Named Boundary 

153) IMPORTANT: If you haven’t already enable both the 2D and a 3D view by selecting 

the F6 key (or the tool will create the Named Boundaries and NOT the sheet and drawing 

models. The sheets may be created at a different time using the Named Boundaries 

Manager) 

154) In this next step we are going to be placing Named Boundary’s to indicate where we want 

to cut cross sections.  We are going to show you two ways to open the Named Boundary 

Tool. 

The first way to access the Named Boundary tool is to select the OpenRoads Modeling 

Workflow ➔ Drawing Production tab ➔ Named Boundary tool.  

 

 

 

 

 

This method unfortunately does not set up the Named Boundary Attributes. 

 

The second way to open the Named Boundary tool is to Right-Click and hold in a blank area 

in the Default 2D window (typically View #1) 
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The benefit of using the right click option is that ORD will automatically set up the Attributes 

for the Named Boundary. 

Before 

 

After 
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155) After the Place Named Boundary dialog opens, select the Civil Cross Section icon 

 

a. Use a Drawing Seed: XS Sheet – 20 Scale 

b. First Identify the Path Element 

c. Set the following Dialog Settings:  

 

d. Once the dialog has been filled out then Accept/Reject to either place the named 

boundary or end the tool. 
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19.12 End Area Volume Reporting: 

156) Within the OpenRoads Modeling Workflow select the Home Tab ➔ Model Analysis 

and Reporting Section ➔ Civil Analysis Tools ➔ End Area Volume Report tool. 

 

 

 

 

 

 

 

 

 

 

 

 

157) Choose the RTE179 for the Named Boundary Group. 

 

158) In the next prompt, the tool will ask the User to define a Volume Exception by selecting 

the start and stop cross section named boundaries. Once the Volume Exception is defined 

or if there is no Volume Exception, the User can just Reset (Right-Click) to complete and 

create the End Area Volume report. 

  

Note: This will bring up a report that has many other volume reports that are created.  

The importance of this report is that it creates an XML that is attached to each of the 

cross-section shapes that will allow for annotation. 
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19.12.1 Changing the Format Options of the Report: 

159) Select the Tools option in the top left corner of the report and then select Format Options 

 

160) In the Format Options dialog change the following: 

Station  ss+ss.ss 

Cubic Units Check the Convert to Cubic Yards box 

NOTE: Then close the dialog.  In SS4 this dialog was dynamic meaning that if you 

changed a setting it would immediately change the report but in ORD it is not so closing 

the dialog enables the changes made. 
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161) Switch the to the Volumes.xls Report to show the individual types of Volume. 
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162) We used the Measure Area Tool, located under the OpenRoads Modeling Workflow ➔ 

Drawing Tab ➔ Measure Section, to verify the area in the Excavated Rock and 

compared it to the Report on the previous page.  The Flood Method was utilized.  Also 

helpful is turning off all the levels in the Cross Section View except for Volumes-Rock 

Excavated. 
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163) We used the Measure Area Tool, located under the OpenRoads Modeling Workflow ➔ 

Drawing Tab ➔ Measure Section, to verify the area in the Excavated Rock and 

compared it to the Report on the previous page.  The Flood Method was utilized.  Also 

helpful is turning off all the levels in the Cross Section View except for Volumes-Rock 

Excavated. 
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