		Chapter 6: Data Analysis





Learning Objectives in this chapter:
· Understand the Geoprocessing Tools and their functions
· Be able to Export Data as new shapefiles or features
· Know how to define the projection of a shapefile
Data Analysis

6.1 Overview

When you acquire a particular dataset of interest, most of the time it will need to be enhanced in some manner.  This chapter describes how to change the data to make it more appropriate to the scope of the project using several of the tools in Geoprocessing Tools and ArcToolbox.  ArcToolbox can be accessed from either ArcCatalog or ArcMap. 

6.2 Geoprocessing Menu

The Geoprocessing menu is available in the main menu.  It includes the most commonly used tools for analysis.  It also includes an option to search for tools, and a way to open ArcToolbox.  These will be the main functions that you will use when accessing this menu.Geoprocessing Toolbar
[image: ]



The Geoprocessing menu comes with six tools on its menu: Buffer, Clip, Intersect, Union, Merge, and Dissolve. You can customize this list by removing tools or adding your own tools. You can add or remove tools on any menu or toolbar.

An example of each tool found in the Geoprocessing toolbar is provided in this section.


[image: ]Buffer
Creates buffer polygons around input features to a specified distance. An optional dissolve can be performed to combine overlapping buffers.
















[image: ]Clip 
Extracts input features that overlay the clip features.
Use this tool to cut out a piece of one feature class using one or more of the features in another feature class as a "cookie cutter". This is particularly useful for creating a new feature class—also referred to as study area or area of interest (AOI)—that contains a geographic subset of the features in another, larger feature class.







[image: ]Intersect 
Computes a geometric intersection of the input features. Features or portions of features which overlap in all layers and/or feature classes will be written to the output feature class.















[image: ]Union 
Computes a geometric intersection of the Input Features. All features will be written to the Output Feature Class with the attributes from the Input Features, which it overlaps.







[image: ]Merge 
Combines multiple input datasets of the same data type into a single, new output dataset. This tool can combine point, line, or polygon feature classes or tables.
Use the Append tool to combine input datasets with an existing dataset.













[image: ]Dissolve 
Aggregates features based on specified attributes.
















6.3 Search Window

There are two basics ways to find tools: 
· Search using the Search window.
· Browse using the Catalog or ArcToolbox window.

In addition, tools can be found on menus and toolbars. ArcGIS is installed with a few commonly used tools on the Geoprocessing menu, as mentioned above, and you can add tools to any menu or toolbar. 

Using the Search window to search for tools
To open the Search window, do one of the following: 
· Click Geoprocessing > Search For Tools.
· [image: C:\Program Files\ArcGIS\DeveloperKit10.0\Icons\SearchWindowShow32.png]Click the Search        button.
· Click Windows > Search.
· Press CTRL+F.

Tool home page

As illustrated to the right, the Search window has four filters: All, Maps, Data, and Tools. Both the All and Tools filters will return tool results. When searching for tools, the best results are obtained using the Tools filter.
[image: Tools home page]Search Bar



[image: C:\Program Files\ArcGIS\DeveloperKit10.0\Icons\GenericHomeBlue32.png]The Search window Home page button       takes you to the geoprocessing tools home page, illustrated below. The home page lists all installed system toolboxes. You can click the toolbox name to examine the contents of the toolbox—its toolsets and tools. Custom toolboxes (toolboxes that you create) can be examined by clicking the Find My Custom Toolboxes link. 

[image: Note] Note:
Only those custom toolboxes in folders that you index can be found in the Search window. To add a folder to the search index, click the Indexing Options button[image: Index / Search Options].


Searching by name or keyword

If you know the name of a tool, you can enter it in the Search window. If you don't know the name of a tool but can think of some words that describe what you want the tool to do, you can enter the words and search for all tools that match the words.

Search by name or keyword
[image: Using the Search window to find a tool]




Tip:	You can type the first few letters of a tool name to populate the drop down list. You can then highlight an entry in the drop down list using the up and down arrow keys or your mouse. Once you've highlighted the tool, press CTRL+ENTER to open the tool dialog.

Search by name or keyword
[image: Use CTRL+ENTER to open a tool's dialog box]



Working with a search result

There are a number of things you can do with a search item. If you pause the pointer on the item, a short description of the toolbox or tool will be displayed (toolsets do not have descriptions), as illustrated below. The Item Description link in the short description will open the toolbox or tool description, which is essentially the full documentation from the help system but without navigation links. You can also open the item description by clicking the first line of text below the tool name.

Working with search results
[image: Toolboxes and toolsets search result]




A search item contains the path to the item. Click this path to open the Catalog window with the item expanded.

Opening a search item in the catalog window

[image: Click the path link to open Catalog on search item]



You can open the tool dialog box directly from the search item by clicking the tool name. 

Opening a tool

[image: Working with a tool search result]














Using the Catalog window to browse for tools

System toolboxes (those installed on your system with ArcGIS) can be found in the Catalog window by expanding the Toolboxes folder, as illustrated below.

Using the catalog window
[image: The Toolboxes node in the Catalog tree]




Custom toolboxes can be found by browsing to the folder or geodatabase in which they reside.

Once you've found the tool, you can open the dialog box by double-clicking the tool or right-clicking the tool and clicking Open. 

6.4 Using the ArcToolbox window

[bookmark: _GoBack][image: C:\Users\hoskir\Desktop\Capture copy.gif]In any ArcGIS Desktop application, you open the ArcToolbox window with the Show/Hide ArcToolbox Window button       found on the standard toolbar or by clicking Geoprocessing > ArcToolbox. 

You can customize the contents of the ArcToolbox window—adding and removing system and custom toolboxes until you have just those toolboxes that you use most often. The contents of the ArcToolbox window is saved with your map document. The illustration below shows the ArcToolbox window with six system toolboxes and two custom toolboxes (My Data Conversions Tools and My Favorites). 

Customizing theToolbox
[image: ArcToolbox window]




You browse and open tools just as you would with the Catalog window, expanding toolboxes and toolsets until you find the tool you want, then double-clicking the tool to open its dialog box. 

6.5 Exporting Data

Using ArcMap, you are capable of exporting a new dataset from an existing one that contains either selected features or you have the option of exporting the entire dataset. If you are wanting to export specific features that have been selected, a new layer is created containing only the selected features.  The new layer will be added into the table of contents and has the default name of the original dataset with ‘Selection’ tacked onto the end. This layer is only available within this particular map project. This is valuable for quick manipulation of datasets.

However, if the user desires to use this new layer within other ArcGIS applications, the selected features should actually be exported as a shapefile or a feature class in a geodatabase.  Exporting an entire dataset is useful if you have data that is not native in ArcView format.  For example, a Microstation DGN file.  Another good example of when you may want to export data, is if you have aquired data via the TMS toolbar.  This data that populates your map is in Read-Only format.  If you choose to edit any of this information, you must first export the data to your local drive. 

[image: Tip]Tip: The folder that you will save the new data to should not have  spaces in the folder name or in the path to the folder.
To export data, you must first right click on the layer that you want to export.  Scroll down to Data and choose Export Data.

Exporting Data
[image: C:\Users\hoskir\Desktop\Untitled-1.gif]





[image: C:\Program Files\ArcGIS\DeveloperKit10.0\Icons\FolderAdd32.png]You will get the Export Data dialog box.  Choose the coordinate system requirements as either the data frame you are working in, or the data’s original source projection.  Click on the        icon and choose to save the data either as a File or Personal Geodatabase feature class, Shapefile, or a SDE feature class. Save the data in your working location and name it.  ArcMap will save the data and then request if you want to add it to your current ArcMap session.

Exporting Data dialog boxes
[image: C:\Users\hoskir\Desktop\Untitled-1.gif][image: ]



6.6  Projections and Transformations

Project Tool

If you obtain data with different coordinate system information and intend to use all of the data for analysis, permanent projections and coordinate systems should be changed so that they all match.  You can permanently change the projection and coordinate system of a data set using the Project tool found in ArcToolbox>Data Management Tools>Projections and Transformations>Feature>Project.
[image: ]
Project Tool
[image: ]



Define Projection Tool

If you have a data set that is brought into ArcMap that doesn’t have a coordinate system defined for it, you can define the coordinate system by opening the Define Projection tool found in ArcToolbox>Data Management Tools>Projections and Transformations>Define Projection.

Define Projection Tool
[image: C:\Users\hoskir\Desktop\Untitled-1.gif]


This tool overwrites the coordinate system information (map projection and datum) stored with a dataset.  Only use this for datasets that have an unknown or incorrect 
coordinate system defined. You must know the correct coordinate system of the dataset before using this tool.

 ‘Project on the Fly’ in ArcMap

The ArcMap data frame adopts the coordinate system of the first layer added to a new empty map.  If the first data layer added to the map document has a projection correctly defined, other data that has correct coordinate definitions will be projected on the fly to the coordinate system of the data frame when added to the map document.  The newly added data will be displayed in the data frame’s current coordinate system instead of its own.  The ‘Project on the Fly’ utility does not make a permanent change to your data displayed in the map. It is only intended to facilitate mapmaking and cartographic development, and should not be used when analysis is performed with the data or if the data will be edited.

More on Coordinate Systems

To understand projections and coordinate systems you will need to know what these 2 things really are…
A projection is simply a method of making the Earth’s “round” surface look as correct as possible on a flat map.  In order to make an irregular surface translate to a flat surface some stretching and/or compressing is going to happen.  Different projections use different ways of applying this distortion to make these surfaces work together.
A coordinate system refers to imaginary points on the Earth’s surface used to represent a location or reference distances.  Different coordinate systems use different origin points and/or different units of measure.
Combine these 2 items together and you get a projected coordinate system.
The reason different systems are used is that each system has areas that it does a little better than other systems.  Certain systems are more accurate near the equator and others have better precision at the North and South Poles.  Some systems are more accurate in measuring distances within a specific area on the Earth’s surface.  Other systems cover larger areas and do a better job of maintaining consistent measurements over that entire area.
There are 2 primary systems that are used at MoDOT.  The first is State Plane (MoDOT uses a “Modified” State Plane) and the second is Universal Transverse Mercator or UTM.







The “Modified” State Plane system is used because of the accuracy it provides MoDOT during project design and cost estimating.  It breaks the state into 3 separate zones (East, Central, West) and adjusts measurements based on the location of a position within that zone.  The “modification” portion also gives the ability to adjust for elevation differences and gives MoDOT a higher degree of accuracy when figuring earthwork quantities.  State Plane measurements are given in survey feet.

Modified State Plane Zone
[image: C:\Users\hoskir\Desktop\MoDOT Districts.jpg]


UTM is the default system used by ArcGIS and is the base system used by many mapping and GIS applications.  UTM uses primarily the same zone for the entire state of Missouri (although a small portion of the state in the bootheel region is located in a different zone), so there is no “adjustment” or reprojection needed when working with data in different areas of the state.  Universal Transverse Mercator uses meters as its base unit of measure.

UTM Zones
[image: ]



A third system is sometimes used.  This is the World Geodetic System or WGS.  The latest version of this system was established in 1984 and so you may see it referred to as WGS84.  This system uses Latitude and Longitude to define positioning.

WGS System
[image: ]








Overview:

In this exercise you learn to export data and assign a coordinate system.  Create a buffer of a line feature.  Spatially clip data and Change the projection of a dataset.
In the previous exercise you created new shapefiles to show only the data in your project area.  The size and location of the study area will depend on the goal of the project or the data you need to extract for your project.  In this project you need to look at areas of two different extents.  One will be county wide; the second will be a ¼ mile buffer of the new alignment.
In this exercise you will use a few tools that will create an even more concise shapefile, reducing the number of records associated with the project.  This will prepare the data for analysis within the project area.

Step 1

Open ArcMap and in your ArcMap – Getting Started window select Existing Maps > Recent.  Now open the LakeOzarkBypass map you have saved. 
Using the Bookmarks you made select j5p0347g to make sure you are zoomed in to your project.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]
Step 2

First let’s create a buffer around the project area so we can see what type of data lands in the project area.

Create a ¼ mile buffer from the centerline of j5p0347a.

From the Main Toolbar select Geoprocessing > Buffer.

[image: ]

In the Buffer tool window input the following information:

Select the Input Feature that you want to create the buffer around, this will be j5p0347a.dgn Polyline_UTM.
[image: ]
For the Output Feature Class select the      open folder button and browse to the      J:\gis_proj\j5p0347\j5p0347_projectdata.gdb, save the file as j5p0347a_Buffer.

For the distance, enter .25 for Linear unit and change Meters to Miles.

Dissolve Type should be changed to ALL, This will combine the buffer of all the arcs and create one feature.

Select OK.
[image: ]

You should see a processing bar at the bottom of your ArcMap window.  When the process is complete the buffer feature will be added to you document.

[image: ]

Step 3

Repeat the process and create a buffer for the Polylines layer in the group j5p0347g.

Select the Input Feature that you want to create the buffer around, this will be Polylines from the group layer j5p0347g.
[image: ]
For the Output Feature Class select the      open folder button and browse to the      J:\gis_proj\j5p0347\j5p0347_projectdata.gdb, save the file as j5p0347g_Buffer.

For the distance, enter .25 for Linear unit and change Meters to Miles.

Dissolve Type should be changed to All.

Select OK.
[image: ]

Step 4

Turn both of the buffers on you just created.

Your map should now have the feature datasets shown below in the Table of Contents.
[image: ]

Save your map document by selecting File > Save.
Step 5

From the Main Toolbar select Geoprocessing > Merge.

Now we will merge the 2 buffers we just created together.

For the input datasets use the down arrow select j5p0347a_buffer and j5p0347g_buffer.
[image: ]
For the Output Dataset select the      open folder button and browse to the      J:\gis_proj\j5p0347\j5p0347_projectdata.gdb, save the file as quartermile_Buffer_Merge.

[image: ]

Select OK.

After the process runs and the layer quartermile_Buffer_Merge is added to your map, you can remove the j5p0347g_buffer and j5p0347a_buffer layers.

Turn on the quartermile_Buffer_Merge.






Step 6

The next tool you will use will probably be one of the most frequently used tools in the Geoprocessing Menu, the Clip Tool.

This tool will reduce the shapefiles geographic and tabular size to include only the data within your project area.  Working with smaller data files will make your project easier to manage.

Some shapefiles in this document will need to be clipped to make the data more manageable and the results of your analysis more meaningful.

The Hazardous Waste Data selection needs to be clipped using the quartermile_Buffer_Merge.  

From the main toolbar select Geoprocessing > Clip.

[image: ]

Select the input layer to be clipped; Hazwaste_selection.

Select the layer you will use as the clip boundary; quartermile_buffer_merge.
[image: ]
For the Output Dataset select the      open folder button and browse to the      J:\gis_proj\j5p0347\j5p0347_projectdata.gdb, save the file as 
Hazwaste_clip.

Leave the XY Tolerance box blank

[image: ]
Select OK.

Step 7

Open the table for Hazwaste_selection by right clicking on the layer in the Table of Contents and select Open Attribute Table.

[image: ]

Note the number of records.

[image: ]

There are 27,570 records in our Hazwaste_selection.

Do not close the Hazwaste attribute table.

Now open the table for hazwaste_clip using the same method, and note the number of records.

[image: ]

After clipping the data you went from 27,570 records to 53.

In ArcMap 10 tables are now tabbed in the same window.  You can open multiple tables and select the tab of the table you want to see.

Step 8

Remove the Hazwaste_selection file from the Table of Contents.

[image: ]

Save your ArcMap document.











Step 9a

The last portion of this exercise will step you through changing the projection of a shapefile that has a different projection defined but is needed for your project.

Open ArcToobox by selecting the Icon in the Standard Toolbar.

[image: ]

From ArcToobox select Project from the Data Management Tools >  Projections and Transformations > Feature toolbox.

[image: ]


[image: ]Select your Input Dataset  by navigating to      J:\gis_proj\class_data\chapter 06 exercise\citylimit_stateplane_nad27.shp.  Select Add.

Select a destination for your new feature class.  Navigate to your project file geodatabase, and name your feature class citylimit_nad83.

[image: ]

Step 9b

[image: ]Next you will need to select your new coordinate system.
Click on       Output Coordinate System button.

Click on the Select button to select a predefined coordinate system

The Missouri GIS Data Standard is UTM – NAD 83 – Zone 15 North.
[image: C:\Users\hoskir\Desktop\Untitled-1.gif]

Double click on Projected Coordinate System.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]






Double click on UTM.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]

Double click on NAD 1983.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]







Select NAD 1983 UTM Zone 15N.prj.  Click Add to add the projection file to your dataset.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]

Select OK.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]


Step 9c

For the Geographic Transformation, use the drop down menu to select NAD_1927_To_NAD_1983_NADCON.  Select OK.

[image: C:\Users\hoskir\Desktop\Untitled-1.gif]

Your new feature class, citylimit_nad83 will be added to your map document.

Step 10

The City Limits dataset you have added is a statewide coverage.

Let’s use the Clip Tool to clip the Citylimit_nad83 feature class on the COUNTY layer.

Select Geoprocessing > Clip on the Main Toolbar.

Use citylimit_nad83 for the Input Feature.

For the Clip Features use the COUNTY layer.

Save your Feature Class as citylimit_clip in the project geodatabase J:\gis_proj\j5p0347\j5p0347_projectdata.gdb

[image: ]






























Step 11

Remove the citylimit_nad83 feature class.

Your map document should look similar to the image below.
Compare the Table of Contents in the image shown below with your Map Document.  Your list of datasets should have the same name and content.  If you have any additional datasets, remove them from your Map Document.

[image: ]

Step 12

Save your map document by clicking File > Save in ArcMAP.


End of Chapter 6 Exercise.
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